Bug 989201 - PAM issue prevents atd sending mail
PAM issue prevents atd sending mail
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 1005323 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 05:44 EDT by Paul Howarth
Modified: 2013-12-31 22:32 EST (History)
9 users (show)

See Also:
Fixed In Version: at-3.1.13-13.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 06:44:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2013-07-28 05:44:20 EDT
Since updating to F-19, my at jobs have been unable to send mail. This appears to be a PAM issue, as evidenced by these journal entries:

# journalctl -b | grep atd
Jul 27 00:10:00 zion.intra.city-fan.org atd[23419]: pam_unix(atd:session): session opened for user paul by (uid=0)
Jul 27 00:16:28 zion.intra.city-fan.org atd[23419]: pam_loginuid(atd:session): set_loginuid failed
Jul 27 00:16:28 zion.intra.city-fan.org atd[23419]: pam_unix(atd:session): session opened for user paul by (uid=0)
Jul 27 00:16:28 zion.intra.city-fan.org atd[23419]: Cannot make/remove an entry for the specified session

My at job ran at 00:10:00, completed successfully, and then at 00:16:28 tried to mail the output to me but never sent anything.

Last night I tried commenting out the pam_loginuid line from /etc/pam.d/atd and atd was subsequently able to mail me its output.
Comment 1 Göran Uddeborg 2013-08-16 18:06:15 EDT
I don't see those messages in my log, but your workaround helped for me too.  (Thanks for the tip!)
Comment 2 Dean Hunter 2013-10-28 13:33:40 EDT
Thank you for the work-around. It works for me. Do you have any idea what I loose by commenting pam_loginuid.so?
Comment 3 Marcela Mašláňová 2013-11-12 06:47:20 EST
*** Bug 1005323 has been marked as a duplicate of this bug. ***
Comment 4 Marcela Mašláňová 2013-11-12 06:48:31 EST
Thanks Paul. I had the same problem with cronie. This is a correct fix. I'll fix it in F20 and F19 branches.
Comment 5 Marcela Mašláňová 2013-12-05 06:44:57 EST
Please, add the pam_loginuid.so back. It can solve some cases, but the configuration is not safe without it. PAM authentication in code of at is now improved and working properly.
Comment 6 Fedora Update System 2013-12-05 06:47:41 EST
at-3.1.13-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/at-3.1.13-13.fc19
Comment 7 Fedora Update System 2013-12-05 06:48:50 EST
at-3.1.13-14.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/at-3.1.13-14.fc20
Comment 8 Paul Howarth 2013-12-05 07:34:40 EST
at-3.1.13-13.fc19 works for me.
Comment 9 Marcela Mašláňová 2013-12-05 07:55:23 EST
(In reply to Paul Howarth from comment #8)
> at-3.1.13-13.fc19 works for me.

Thanks, I tested it only on my laptop, so I'm glad it's working for everyone.
Comment 10 Fedora Update System 2013-12-27 00:57:23 EST
at-3.1.13-14.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-12-31 22:32:12 EST
at-3.1.13-13.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.