Bug 98926 - An error appears when you get a login from an syntax-error in jave_jre.csh
Summary: An error appears when you get a login from an syntax-error in jave_jre.csh
Status: CLOSED DUPLICATE of bug 62105
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
low
low
Target Milestone: ---
Assignee: Lillian Angel
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-10 15:04 UTC by Geoff Dolman
Modified: 2008-07-14 03:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Geoff Dolman 2003-07-10 15:04:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:

The text of the file /etc/profile.d/java_jre.csh contains the following:


root = /opt/IBMJava2-131
if ( $root/jre/bin !~ "${path}" ) then
    set path = ( $root/jre/bin $path )
endif

The first line obviously is a syntax error in csh which means that when users
with c shells loginto the machine they get an error, "root: command not found"
after the login-banner messages.

Version-Release number of selected component (if applicable):
syntax error in /etc/profile.d/java_jre.csh

How reproducible:
Always

Steps to Reproduce:
1. get a login on the machine
2.
3.
    

Actual Results:  "root: command not found"

Expected Results:  nothing

Additional info:

Comment 4 Thomas Fitzsimmons 2004-04-06 21:24:05 UTC

*** This bug has been marked as a duplicate of 62105 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:57:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.