Bug 62105 - New version 1.3.1-2 has broken /etc/profile.d/java_jre.csh
New version 1.3.1-2 has broken /etc/profile.d/java_jre.csh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: IBMJava2-JRE (Show other bugs)
2.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Karen Bennet
:
: 64929 69643 98926 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-27 10:48 EST by Nils Philippsen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2002-03-27 10:48:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
/etc/profile.d/java_jre.csh is not syntactically correct


Version-Release number of selected component (if applicable):

[ I know that this version is _not_ in the public beta, but the internal
  beta misses the IBMJava2-JRE component ]

IBMJava2-JRE-1.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install package
2. "su -" to a user with /bin/csh as login shell


Actual Results:  """
root: Command not found.
root: Undefined variable.
"""


Expected Results:  Correctly set environment


Additional info:

FIX: Replace "root = ..." with "set root = ..." in the first line of the script.
Comment 1 Preston Brown 2002-03-27 11:11:05 EST
 fixed in 1.3.1-3 and later.
Comment 2 Nils Philippsen 2002-08-27 07:30:20 EDT
Not really fixed (in 1.3.1-3):

--- 8< ---
[root@ls3130 i386]# head -n 1 /etc/profile.d/java_*csh
==> /etc/profile.d/java_jre.csh <==
root = /opt/IBMJava2-131

==> /etc/profile.d/java_sdk.csh <==
root = /opt/IBMJava2-131
[root@ls3130 i386]# rpm -Vf /etc/profile.d/java_*csh
[root@ls3130 i386]# rpm -qf /etc/profile.d/java_*csh
IBMJava2-JRE-1.3.1-3
IBMJava2-SDK-1.3.1-3
--- >8 ---
Comment 3 Nils Philippsen 2002-08-27 07:31:54 EDT
*** Bug 64929 has been marked as a duplicate of this bug. ***
Comment 4 Nils Philippsen 2002-08-27 07:33:00 EDT
*** Bug 69643 has been marked as a duplicate of this bug. ***
Comment 5 Nils Philippsen 2002-08-27 07:35:54 EDT
PS: As you can see above, the same bug exists in IBMJava2-SDK-1.3.1-3. Shall I
open an own bug for it?
Comment 6 Preston Brown 2002-12-10 10:59:45 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-199.html
Comment 7 Thomas Fitzsimmons 2004-04-06 17:24:07 EDT
*** Bug 98926 has been marked as a duplicate of this bug. ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:48:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.