Bug 989276 - OPENMEAP on OPENSHIFT install : No such file or directory
OPENMEAP on OPENSHIFT install : No such file or directory
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 21:34 EDT by Yones Lebady
Modified: 2015-05-14 22:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:27:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error screenshot (316.88 KB, image/png)
2013-07-28 21:34 EDT, Yones Lebady
no flags Details

  None (edit)
Description Yones Lebady 2013-07-28 21:34:13 EDT
Created attachment 779480 [details]
Error screenshot

Description of problem:
Unable to install OPENMEAP over JBOSS EWS 2.0 cartridge on OPENSHIFT free trial gear 

Version-Release number of selected component (if applicable):


How reproducible:
INSTALL OPENMEAP quick start on a gear.

Steps to Reproduce:
1.
2.
3.

Actual results:
cp: cannot stat `/var/lib/openshift/51f5c3bee0b8cd950f002e95/jbossews//webapps/ROOT.war': No such file or directory

Expected results:
correct install
/var/lib/openshift/51f...e95/jbossews/webapps/ROOT.war

Additional info:
There is an error anywhere in the installation script that throws a double slash in the installation path:
/var/lib/openshift/51f...e95/jbossews//webapps/ROOT.war
                                     ^^
                                     ^^
Comment 1 Andy Grimm 2013-08-15 13:13:57 EDT
The double slash is a red herring, and this is directly related to
https://bugzilla.redhat.com/show_bug.cgi?id=980321

There's an implicit assumption in that bugfix that "ROOT.war" will always exist, but the OpenMEAP quickstart directs users to a specific URL: 

https://openmeap-$yournamespace.rhcloud.com/openmeap-admin-web/interface/

ROOT.war in a successfully deployed OpenMEAP app in OpenShift is just the stuff we put in jbossews/template/src.  So, it seems like simply verifying the existence of the source before copying it would be sufficient.

Also note that if you make a bare jbossews app in OpenShift and then merge in OpenMEAP code, is works fine, because post_install only runs at cartridge install time.  So in order to test a fix for this, you _must_ use "--from-code".
Comment 2 Yujie Zhang 2013-08-16 05:42:02 EDT
Tested on devenv_3660, tried to create OpenMEAP application from website or using --from-code, but all met "cp: cannot stat `/var/lib/openshift/426114806412954633764864/jbossews//webapps/ROOT.war': No such file or directory " error. 
It can work correct when creating it maunally from github repo, so --from-code is still not working.
Comment 3 Andy Grimm 2013-08-16 08:25:54 EDT
Of course it's not working; the bug has not been fixed yet.  I merely suggested what the fix would be.
Comment 5 Wei Sun 2013-09-22 04:25:33 EDT
Will verify this bug after pull request is merged.
Comment 6 Wei Sun 2013-09-24 22:44:47 EDT
Will verify this bug after pull request is merged.
Comment 7 openshift-github-bot 2013-09-25 12:47:05 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/0aabe9026232b33542a78985b86018d6d54ebbb8
Bug 989276 - Check for existence of ROOT.war before attempting to copy it
Comment 8 Tian Feng 2013-09-25 22:55:19 EDT
Test on devenv_3829 and can create OpenMEAP application successfully via web console. So verify this bug, thanks!

Note You need to log in before you can comment on or make changes to this bug.