Bug 989419 - Bond0 generated automatically when only create Bond[1-9]
Bond0 generated automatically when only create Bond[1-9]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: TestOnly
: 1008796 (view as bug list)
Depends On: 987840
Blocks: rhevh-for-rhev-3.3
  Show dependency treegraph
 
Reported: 2013-07-29 05:00 EDT by wanghui
Modified: 2014-09-24 11:09 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-6.el6
Doc Type: Bug Fix
Doc Text:
When creating "bond" 1 to 9, 'bond' zero would be generated automatically in TUI, which caused a problem as it had no member. This was fixed in a later build, onlybonds 1 to 9 are created in TUI.
Story Points: ---
Clone Of: 987840
Environment:
Last Closed: 2014-01-21 14:47:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
after create bond1 (50.20 KB, image/png)
2013-07-29 05:19 EDT, wanghui
no flags Details

  None (edit)
Description wanghui 2013-07-29 05:00:56 EDT
+++ This bug was initially created as a clone of Bug #987840 +++

Description of problem:
When only create bond[1-9], bond0 will generated automatically. And the bond0 will be misunderstanding because it has no member. So should not generated bond0 in TUI.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-3.999.999.20130716190656git4e57356.2850.fc18.src.rpm
ovirt-node-3.0.0-3.999.20130716190656git4e57356.fc18.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install ovirt-node
2. Create bond1.
3. Check in TUI.

Actual results:
In step3, bond0 generated automatically. And bond0 can be configured as well.

Expected results:
It should not let bond0 display in TUI and not allow it to be configured.

Additional info:
Comment 2 wanghui 2013-07-29 05:19:53 EDT
Created attachment 779698 [details]
after create bond1
Comment 3 wanghui 2013-07-29 05:21:49 EDT
This issue can be reproduced on the fellow bulid:
rhev-hypervisor6-6.5-20130725.0.el6
ovirt-node-3.0.0-6.1.el6.noarch

So need to clone it from ovirt-node upstream to downstream to track this issue.
Comment 5 wanghui 2013-10-28 02:21:41 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

Test steps:
1. Clear install rhevh-6.5-20131024.1.0.iso.
2. Create bond2.
3. Check in TUI.

Test results:
1.It only create bond2 in TUI.

This bug is fixed in rhevh-6.5-20131024.1.0.iso. So I will change the status from ON_QA to VERIFIED.
Comment 6 Fabian Deutsch 2013-12-18 15:48:33 EST
*** Bug 1008796 has been marked as a duplicate of this bug. ***
Comment 7 Cheryn Tan 2014-01-08 00:36:37 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 8 Charlie 2014-01-15 23:53:56 EST
Hi, could you give me a quick synopsis of this bug, cause, how it was fixed, for the doctext? Thanks.
Comment 10 errata-xmlrpc 2014-01-21 14:47:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.