Bug 989435 - Setting ACL entries fails with glusterfs-3.4.0.12rhs
Setting ACL entries fails with glusterfs-3.4.0.12rhs
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Anand Avati
Anush Shetty
: Regression, TestBlocker
Depends On:
Blocks: 957769 994392
  Show dependency treegraph
 
Reported: 2013-07-29 05:20 EDT by Anush Shetty
Modified: 2015-09-01 19:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.18rhs-1
Doc Type: Known Issue
Doc Text:
Cause: On the gluster volume, ACL setting doesn't work as expected due to the caching of metadata in client side. Consequence: the ACL setting with 'setfacl' is not visible from 'getfacl' command. Workaround (if any): disable 'stat-prefetch' (or md-cache) translator by 'gluster volume set <VOL> stat-prefetch disable'. Result: After disabling the 'stat-prefetch', ACLs works fine on gluster mount.
Story Points: ---
Clone Of:
: 994392 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:29:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sosreport of 10.70.37.49 . The RHS client was also mounted was this machine. (1.58 MB, application/x-xz)
2013-07-29 05:48 EDT, Anush Shetty
no flags Details
sosreport of 10.70.37.120 (1.58 MB, application/x-xz)
2013-07-29 05:48 EDT, Anush Shetty
no flags Details
sosreport of 10.70.37.132 (1.61 MB, application/x-xz)
2013-07-29 05:50 EDT, Anush Shetty
no flags Details
sosreport of 10.70.37.208 (1.59 MB, application/x-xz)
2013-07-29 05:50 EDT, Anush Shetty
no flags Details

  None (edit)
Description Anush Shetty 2013-07-29 05:20:16 EDT
Description of problem: Setting ACL entries to files on RHS fails.


Version-Release number of selected component (if applicable): glusterfs-3.4.0.12rhs


How reproducible: Consistenly 


Steps to Reproduce:
1. Create a 2x2 Distributed-Replicate volume

2. Mount RHS client
   mount -t glusterfs -o acl 10.70.37.49:acl /mnt/gluster

3. Create file on mount point and set ACL entries on the file
   
   # touch file1

   [root@rhs3 gluster]# ls
   file1

   [root@rhs3 gluster]# getfacl file1
   # file: file1
   # owner: root
   # group: root
   user::rw-
   group::r--
   other::r--

   [root@rhs3 gluster]# setfacl -m u:test:r-- file1

   [root@rhs3 gluster]# getfacl file1
   # file: file1
   # owner: root
   # group: root
   user::rw-
   group::r--
   other::r--



Actual results:

Setfacl command fails to set acl entries.


Expected results:

This is a regression. Setting ACL entries should succeed. 

Additional info:

# gluster volume info acl
 
Volume Name: acl
Type: Distributed-Replicate
Volume ID: 4c8234b4-8d74-4048-97a9-0d2f519996d1
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.70.37.49:/glance2/s1
Brick2: 10.70.37.120:/glance2/s2
Brick3: 10.70.37.132:/glance2/s3
Brick4: 10.70.37.208:/glance2/s4
Comment 2 Anush Shetty 2013-07-29 05:48:00 EDT
Created attachment 779714 [details]
Sosreport of 10.70.37.49 . The RHS client was also mounted was this machine.
Comment 3 Anush Shetty 2013-07-29 05:48:52 EDT
Created attachment 779715 [details]
sosreport of 10.70.37.120
Comment 4 Anush Shetty 2013-07-29 05:50:01 EDT
Created attachment 779716 [details]
sosreport of 10.70.37.132
Comment 5 Anush Shetty 2013-07-29 05:50:43 EDT
Created attachment 779717 [details]
sosreport of 10.70.37.208
Comment 6 Amar Tumballi 2013-07-29 13:26:43 EDT
Can you confirm if doing 'gluster volume set <VOL> stat-prefetch off' and doing the same operations fixes the problem?

Next question is, if there is a work around, is it a blocker?
Comment 7 Anush Shetty 2013-07-30 02:07:02 EDT
(In reply to Amar Tumballi from comment #6)
> Can you confirm if doing 'gluster volume set <VOL> stat-prefetch off' and
> doing the same operations fixes the problem?
> 
> Next question is, if there is a work around, is it a blocker?

It is not really about setting stat-prefetch off. But after any graph change, I see that setting ACLs work.
Comment 8 Amar Tumballi 2013-07-30 07:47:35 EDT
If you disable 'stat-prefetch', no more graph changes are required. We are working on a fix for this. But till that time, (for all ACL tests) can you proceed with stat-prefetch disabled.
Comment 10 Anush Shetty 2013-08-08 02:28:16 EDT
Verified with glusterfs-3.4.0.18rhs-1.el6rhs.x86_64
Comment 11 Scott Haines 2013-09-23 18:29:53 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.