Bug 994392 - Setting ACL entries fails with glusterfs-3.4.0
Setting ACL entries fails with glusterfs-3.4.0
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: access-control (Show other bugs)
mainline
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Anand Avati
: Regression, TestBlocker
Depends On: 989435
Blocks: 957769
  Show dependency treegraph
 
Reported: 2013-08-07 03:56 EDT by Amar Tumballi
Modified: 2015-09-01 19:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 989435
Environment:
Last Closed: 2014-04-17 07:45:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-07 03:58:26 EDT
REVIEW: http://review.gluster.org/5513 (md-cache: fix xattr caching code in getxattr) posted (#2) for review on master by Anand Avati (avati@redhat.com)
Comment 2 Anand Avati 2013-08-07 04:01:46 EDT
REVIEW: http://review.gluster.org/5513 (md-cache: fix xattr caching code in getxattr) posted (#3) for review on master by Anand Avati (avati@redhat.com)
Comment 3 Anand Avati 2013-08-07 06:35:08 EDT
COMMIT: http://review.gluster.org/5513 committed in master by Anand Avati (avati@redhat.com) 
------
commit 1feaebfe0ae140ecafd5c37a0ce1bb5f0a1ac0cf
Author: Anand Avati <avati@redhat.com>
Date:   Wed Aug 7 01:30:42 2013 -0700

    md-cache: fix xattr caching code in getxattr
    
    Bad condition check, fix it!
    
    Change-Id: I6e047de70f77d7b98b2ca771a467f14a76fd62fe
    BUG: 994392
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5513
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 5 Anand Avati 2013-09-05 06:36:28 EDT
REVIEW: http://review.gluster.org/5805 (md-cache: fix xattr caching code in getxattr) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 6 Anand Avati 2013-09-05 11:10:34 EDT
REVIEW: http://review.gluster.org/5805 (md-cache: fix xattr caching code in getxattr) posted (#2) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 7 Anand Avati 2013-09-06 00:24:44 EDT
REVIEW: http://review.gluster.org/5805 (md-cache: fix xattr caching code in getxattr) posted (#3) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 8 Anand Avati 2013-09-06 03:40:44 EDT
REVIEW: http://review.gluster.org/5805 (md-cache: fix xattr caching code in getxattr) posted (#4) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 9 Anand Avati 2013-09-07 10:58:49 EDT
REVIEW: http://review.gluster.org/5805 (md-cache: fix xattr caching code in getxattr) posted (#5) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 10 Anand Avati 2013-09-09 20:18:04 EDT
COMMIT: http://review.gluster.org/5805 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit cf5a6e9756d52991f4a0406639c422b01e76b053
Author: Anand Avati <avati@redhat.com>
Date:   Wed Aug 7 01:30:42 2013 -0700

    md-cache: fix xattr caching code in getxattr
    
    Bad condition check, fix it!
    
    Change-Id: I6e047de70f77d7b98b2ca771a467f14a76fd62fe
    BUG: 994392
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5513
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-on: http://review.gluster.org/5805
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 12 Niels de Vos 2014-04-17 07:45:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.