Bug 989516 - SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from using the 'net_bind_service' capabilities.
SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from using ...
Status: CLOSED DUPLICATE of bug 997142
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:df69b638c429d28f0ede8800c3d...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 08:25 EDT by Marco Nolden
Modified: 2013-09-09 12:06 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-71.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 12:06:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
bzf: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Marco Nolden 2013-07-29 08:25:01 EDT
Description of problem:
NFS home, NIS authentication
SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from using the 'net_bind_service' capabilities.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that dbus-daemon-launch-helper should have the net_bind_service capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon-lau /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Objects                 [ capability ]
Source                        dbus-daemon-lau
Source Path                   /usr/lib64/dbus-1/dbus-daemon-launch-helper
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.6.12-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-65.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-29 14:16:28 CEST
Last Seen                     2013-07-29 14:18:07 CEST
Local ID                      c65170fd-c248-4d08-9c5a-44037f2474f6

Raw Audit Messages
type=AVC msg=audit(1375100287.527:3134): avc:  denied  { net_bind_service } for  pid=8263 comm="dbus-daemon-lau" capability=10  scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=capability


type=SYSCALL msg=audit(1375100287.527:3134): arch=x86_64 syscall=bind success=yes exit=0 a0=4 a1=7fff0b8e4f40 a2=10 a3=9 items=0 ppid=8262 pid=8263 auid=4294967295 uid=81 gid=81 euid=0 suid=0 fsuid=0 egid=81 sgid=81 fsgid=81 ses=4294967295 tty=(none) comm=dbus-daemon-lau exe=/usr/lib64/dbus-1/dbus-daemon-launch-helper subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: dbus-daemon-lau,system_dbusd_t,system_dbusd_t,capability,net_bind_service

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Fedora Update System 2013-08-20 04:25:20 EDT
selinux-policy-3.12.1-71.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-71.fc19
Comment 2 Fedora Update System 2013-08-20 20:14:31 EDT
Package selinux-policy-3.12.1-71.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-71.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15088/selinux-policy-3.12.1-71.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-08-21 20:52:05 EDT
selinux-policy-3.12.1-71.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Marco Nolden 2013-08-26 10:22:24 EDT
Problem persists in selinux-policy-3.12.1-73.fc19.noarch
Comment 5 Miroslav Grepl 2013-08-29 03:33:21 EDT
Do you know what you were doing when this happened?
Comment 6 Daniel Walsh 2013-08-29 08:50:53 EDT
bzf, if you run in enforcing mode does everything work?

It looks like NIS is causing a root process to bind to a port < 1024.
Comment 7 Marco Nolden 2013-08-29 09:01:59 EDT
It happens several times per day during desktop use. I could not relate it to a certain action but I will try to enable enforcing mode and see if anything fails.
Comment 8 Daniel Walsh 2013-09-04 15:24:53 EDT
Any update?
Comment 9 Marco Nolden 2013-09-05 07:42:40 EDT
I did the following:

I enabled enforcing mode but could not observe anything strange.

Back to permissive mode I could reproduce it. I have a custom "i3 + GNOME session". After login i3 does not start properly (this behaviour is new since FC19, it worked on FC18). I switch to the console <Ctrl-Alt-F2>, login and enter:

export DISPLAY=:0.0
i3

Then this SELinux warning appears, as well as the one I just reported in bug 1004737
Comment 10 Marco Nolden 2013-09-05 07:45:30 EDT
(In reply to Marco Nolden from comment #9)

> 
> Then this SELinux warning appears, as well as the one I just reported in bug
> 1004737

and bug 997142
Comment 11 Marco Nolden 2013-09-05 07:47:47 EDT
And another info: while filing these comments, the dbus-daemon-launch-helper alert appeared again, without doing anything special
Comment 12 Marco Nolden 2013-09-06 08:59:30 EDT
Description of problem:
Also happens after login to a LXDE session

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.10-200.fc19.x86_64
type:           libreport
Comment 13 Miroslav Grepl 2013-09-09 12:06:03 EDT

*** This bug has been marked as a duplicate of bug 997142 ***

Note You need to log in before you can comment on or make changes to this bug.