Bug 98964 - mousecnofig crashes if you change to serial mouse from another type
Summary: mousecnofig crashes if you change to serial mouse from another type
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 102648 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-10 22:10 UTC by Gordon Messmer
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-22 21:36:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mouseconfig traceback (517 bytes, text/plain)
2003-09-02 06:03 UTC, Gordon Messmer
no flags Details

Description Gordon Messmer 2003-07-10 22:10:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Red Hat Linux was installed with another type of mouse.  After installation,
/etc/sysconfig/mouse contained this text:

FULLNAME="serial"
MOUSETYPE="ms3"
XEMU3="no"
XMOUSETYPE="ms3"

When "mouseconfig" was run to change the configuration to "Generic - 3 Button
Mouse (serial)", the program would crash trying to reference the "DEVICE" item
in one of its dictionary variables.  Adding DEVICE=/dev/ttyS0 to
/etc/sysconfig/mouse allowed the program to operate normally.

Please fix the program to initialize all required variables to default values
before loading the config file.


Version-Release number of selected component (if applicable):
redhat-config-mouse-1.0.5-1

How reproducible:
Didn't try

Steps to Reproduce:
1. Install with non-serial mouse
2. run mouseconfig
3. select "Generic - 3 Button Mouse (serial)"
4. hit the "OK" button
    

Actual Results:  program crashes

Expected Results:  program should show the serial devices available.

Additional info:

Comment 1 Brent Fox 2003-08-28 21:39:13 UTC
Can you attach the debug output when the program crashes?

Comment 2 Gordon Messmer 2003-09-02 06:03:34 UTC
Created attachment 94136 [details]
mouseconfig traceback

Comment 3 Brent Fox 2003-09-22 21:36:14 UTC
Should be fixed in redhat-config-mouse-1.1.1-1.  Thanks for your report.

Comment 4 Brent Fox 2003-10-22 18:17:02 UTC
*** Bug 102648 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.