Bug 102648 - traceback, KeyError: DEVICE
traceback, KeyError: DEVICE
Status: CLOSED DUPLICATE of bug 98964
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-19 09:29 EDT by Michael Schwendt
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2003-08-19 09:29:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When after the symptoms described in bug 102647 I switch to virtual console and
run mouseconfig, then exit with "OK", I get this Python traceback reproducibly:

  File "/usr/share/redhat-config-mouse/redhat-config-mouse.py", line 59, in ?
    useTextMode()
  File "/usr/share/redhat-config-mouse/redhat-config-mouse.py", line 23, in
useTextMode
    app = mouse_tui.childWindow()
  File "/usr/share/redhat-config-mouse/mouse_tui.py", line 157, in __init__
    rc = MouseDeviceWindow()(screen, mouse)
  File "/usr/share/redhat-config-mouse/mouse_tui.py", line 52, in __call__
    if choices[choice] == mouse.info["DEVICE"][5:]:
KeyError: DEVICE

[...]

I get the same when I 

  # rm -f /etc/sysconfig/mouse
  # mouseconfig

then select my "Generic - 3 Button Mouse (serial)" on /dev/tty1 and confirm with
"OK".
Comment 1 Brent Fox 2003-10-22 14:17:00 EDT

*** This bug has been marked as a duplicate of 98964 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.