Bug 989909 - [Neutron] Network name/ID is missing from error message when importing existing network ID on DC
[Neutron] Network name/ID is missing from error message when importing existi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
medium Severity high
: ---
: 3.3.0
Assigned To: Lior Vernia
yeylon@redhat.com
network
:
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-07-30 03:12 EDT by Meni Yakove
Modified: 2016-02-10 14:50 EST (History)
9 users (show)

See Also:
Fixed In Version: is22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20604 None None None Never
oVirt gerrit 20605 None None None Never

  None (edit)
Description Meni Yakove 2013-07-30 03:12:53 EDT
Description of problem:	
When importing neutron network with ID that already exist in the datacenter the network name/ID is missing in the error:

Error while executing action: Cannot add Network. The external network already exists as '${NetworkName}' in the data center.
 

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.11.master.el6ev.noarch

Steps to Reproduce:
1.Import network from neutron to DC1
2.Rename the imported network on DC1
3.import the same network from neutron to DC1

Actual results:
get '${NetworkName}' for network name/ID

Expected results:
Error should be with the network name/ID

Additional info:
Comment 1 Lior Vernia 2013-10-08 07:02:00 EDT
Fixed by simply not displaying DCs where the network had already been imported.
Comment 2 Lior Vernia 2013-11-10 03:42:08 EST
Please note that the patch didn't fix the error message, but rather made it impossible to import a network to a DC where it exists. And now as I'm writing this, I'm thinking that there's probably a bug if the network had already been imported to all DCs :)
Comment 3 awinter 2013-11-17 06:10:55 EST
Not fixed.

Now when I try to import a network with the same name as another network, I get:
"Error while executing action: User is not authorized to perform this action."

(Also when trying to add a network with existing vlan)

A bug for those messages was opened:
https://bugzilla.redhat.com/show_bug.cgi?id=1031366


(IS23 - Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.33.beta1.el6ev)


Lior - About your comments, now when a network is imported to all the DCs, the DC's drop box in the import pop up window is empty and small
Comment 4 Lior Vernia 2013-11-17 06:29:12 EST
Amichay, what you're describing isn't a failure of the fix for this bug, it's the description of another bug. The bug here was about trying to import a network that had already existed in the DC (which is now impossible, because the only DCs shown are those where the network doesn't yet exist). You're talking about a network that has the same name as another network in the DC (but it's a different network).
Comment 5 awinter 2013-11-17 06:40:07 EST
You are correct - sorry.

I thought you meant to write the name of the network in the error message but like you said, *it is not impossible to import a network twice to the same DC*
Comment 7 Itamar Heim 2014-01-21 17:32:09 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:32:10 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.