This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 989992 - UI Activation key remove system group the 'Remove' button should be disabled if no system-group is selected
UI Activation key remove system group the 'Remove' button should be disabled ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Tazim Kolhar
: Triaged
: 989985 (view as bug list)
Depends On: 989985
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2013-07-30 04:57 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 989985
Environment:
Last Closed: 2014-07-02 10:07:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove System Group (50.50 KB, image/png)
2013-07-30 05:07 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2013-07-30 04:57:10 EDT
+++ This bug was initially created as a clone of Bug #989985 +++

Description of problem:
UI Activation key remove system group the 'Remove' button should be disabled if no system-group is selected

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.970.aad75f0.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.970.aad75f0.el6.noarch
katello-headpin-1.4.2-1.git.970.aad75f0.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
katello-common-1.4.2-1.git.970.aad75f0.el6.noarch
katello-headpin-all-1.4.2-1.git.970.aad75f0.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=****

Steps to Reproduce:
1.Login to UI Headpin
2.Create a Activation key
3.Add  system group to activation key
4.In the UI activation key, 'Remove' is always,
  enabled even though no system group is selected to remove

Actual results:
'Remove' button is always,
 enabled even though no system group is selected to remove

Expected results:
'Remove' should be disabled until we select the system-group to delete

Additional info:

--- Additional comment from Tazim Kolhar on 2013-07-30 04:52:17 EDT ---
Comment 1 Tazim Kolhar 2013-07-30 05:07:45 EDT
Created attachment 780473 [details]
Remove System Group
Comment 2 Tazim Kolhar 2013-07-30 09:06:46 EDT
*** Bug 989985 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2013-09-17 00:21:31 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 6 Brad Buckingham 2013-10-03 15:34:55 EDT
katello pull request: 

https://github.com/Katello/katello/pull/3089
Comment 9 Mike McCune 2013-10-17 17:02:22 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 10 Tazim Kolhar 2014-04-28 01:40:00 EDT
VERIFIED
Comment 11 Bryan Kearney 2014-07-02 10:07:59 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.