Bug 990495 - subscription-manager can't get the virt.uuid in the RHEL5.10Server IA64/FV
subscription-manager can't get the virt.uuid in the RHEL5.10Server IA64/FV
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
ia64 Linux
unspecified Severity high
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Reopened
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-31 05:59 EDT by Liushihui
Modified: 2013-08-07 08:57 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 08:57:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2013-07-31 05:59:30 EDT
Description of problem:
The virt.uuid is "Unkown" in the RHEL5.10Server IA64/FV

Version-Release number of selected component (if applicable):
Host and guest's Linux Version: RHEL5.10-Server-20130725.0

How reproducible:
Always

Steps to Reproduce:
Precondition: 
Host Operating System:Red Hat Enterprise Linux 5.10 IA64
Guest Operating System:Red Hat Enterprise Linux 5.10 IA64 FV

1.Install FV guest on the Xen host, start FV on host successfully.
2.Check the virt.uuid in the guest:
#subscription-manager facts --list | grep virt.uuid

Actual results:
The result as the following:
virt.uuid:Unknown

Expected results:
The virt.uuid shouldn't be "Unknown", it should be auto generate when the vm been created.just like "virt.uuid: 3bfa5f53-f9f3-9827-1111-56cc2bd2a235"

the virt.uuid's value should the same as it in the virt-manager .
Get the virt.uuid as the following steps:
1 Bring up virt-manager
2 In the virt-manager window, Choose the vm, double click 
3 Go to Overview tab,see the uuid


Additional info:
1 If Guest Operating System is "Red Hat Enterprise Linux 5 IA64 PV", it hasn't this problem
2 This problem block virt-who send the host/guest association to the sam server.
Comment 1 Adrian Likins 2013-08-02 17:16:55 EDT
What is the output from 'virt-who' on this system?
Comment 2 Liushihui 2013-08-04 23:02:39 EDT
Add guest "FVTEST", the rhsm.log as the following:

Before add guest "FVTEST"
2013-08-01 20:26:05,409 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['03a2af12-55c9-e7bb-7cd3-1044ab1a0509', '60f0868b-b5fe-2d3a-08c4-509b68b1f67d', '9641f0ce-7158-9aef-dcc9-9c6d5081184f']
2013-08-01 20:26:16,133 [DEBUG]  @virt.py:62 - Virtual machine found: aaaa: 9641f0ce-7158-9aef-dcc9-9c6d5081184f
2013-08-01 20:26:16,136 [DEBUG]  @virt.py:62 - Virtual machine found: FV-5.10-novirtual: 03a2af12-55c9-e7bb-7cd3-1044ab1a0509
2013-08-01 20:26:16,140 [DEBUG]  @virt.py:62 - Virtual machine found: 5.10_Server_ia64_FV: 60f0868b-b5fe-2d3a-08c4-509b68b1f67d
2013-08-01 20:26:16,141 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['03a2af12-55c9-e7bb-7cd3-1044ab1a0509', '60f0868b-b5fe-2d3a-08c4-509b68b1f67d', '9641f0ce-7158-9aef-dcc9-9c6d5081184f']

After add guest "FVTEST"
2013-08-01 20:26:17,203 [DEBUG]  @virt.py:72 - EVENT: Domain FVTEST(1) Started Booted
2013-08-01 20:26:17,317 [DEBUG]  @virt.py:72 - EVENT: Domain FVTEST(1) Started Booted
2013-08-01 20:26:17,318 [DEBUG]  @virt.py:56 - Virtual machine found: FVTEST: 2907fb1c-6328-90f4-097d-e2feb556d71c
2013-08-01 20:26:17,330 [DEBUG]  @virt.py:62 - Virtual machine found: aaaa: 9641f0ce-7158-9aef-dcc9-9c6d5081184f
2013-08-01 20:26:17,334 [DEBUG]  @virt.py:62 - Virtual machine found: FV-5.10-novirtual: 03a2af12-55c9-e7bb-7cd3-1044ab1a0509
2013-08-01 20:26:17,338 [DEBUG]  @virt.py:62 - Virtual machine found: 5.10_Server_ia64_FV: 60f0868b-b5fe-2d3a-08c4-509b68b1f67d
2013-08-01 20:26:17,339 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['03a2af12-55c9-e7bb-7cd3-1044ab1a0509', '2907fb1c-6328-90f4-097d-e2feb556d71c', '60f0868b-b5fe-2d3a-08c4-509b68b1f67d', '9641f0ce-7158-9aef-dcc9-9c6d5081184f']
2013-08-01 20:26:19,268 [DEBUG]  @virt.py:72 - EVENT: Domain FVTEST(-1) Defined Added
2013-08-01 20:26:19,270 [DEBUG]  @virt.py:72 - EVENT: Domain FVTEST(-1) Defined Added
2013-08-01 20:26:19,274 [DEBUG]  @virt.py:56 - Virtual machine found: FVTEST: 2907fb1c-6328-90f4-097d-e2feb556d71c
2013-08-01 20:26:19,361 [DEBUG]  @virt.py:62 - Virtual machine found: aaaa: 9641f0ce-7158-9aef-dcc9-9c6d5081184f
2013-08-01 20:26:19,363 [DEBUG]  @virt.py:62 - Virtual machine found: FV-5.10-novirtual: 03a2af12-55c9-e7bb-7cd3-1044ab1a0509
2013-08-01 20:26:19,366 [DEBUG]  @virt.py:62 - Virtual machine found: 5.10_Server_ia64_FV: 60f0868b-b5fe-2d3a-08c4-509b68b1f67d
2013-08-01 20:26:19,367 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['03a2af12-55c9-e7bb-7cd3-1044ab1a0509', '2907fb1c-6328-90f4-097d-e2feb556d71c', '60f0868b-b5fe-2d3a-08c4-509b68b1f67d', '9641f0ce-7158-9aef-dcc9-9c6d5081184f']
2013-08-01 20:26:26,873 [DEBUG]  @virt.py:56 - Virtual machine found: FVTEST: 2907fb1c-6328-90f4-097d-e2feb556d71c
2013-08-01 20:26:26,921 [DEBUG]  @virt.py:62 - Virtual machine found: aaaa: 9641f0ce-7158-9aef-dcc9-9c6d5081184f
2013-08-01 20:26:26,925 [DEBUG]  @virt.py:62 - Virtual machine found: FV-5.10-novirtual: 03a2af12-55c9-e7bb-7cd3-1044ab1a0509
2013-08-01 20:26:26,929 [DEBUG]  @virt.py:62 - Virtual machine found: 5.10_Server_ia64_FV: 60f0868b-b5fe-2d3a-08c4-509b68b1f67d
2013-08-01 20:26:26,929 [DEBUG]  @subscriptionmanager.py:81 - Sending list of uuids: ['03a2af12-55c9-e7bb-7cd3-1044ab1a0509', '2907fb1c-6328-90f4-097d-e2feb556d71c', '60f0868b-b5fe-2d3a-08c4-509b68b1f67d', '9641f0ce-7158-9aef-dcc9-9c6d5081184f']
Comment 7 Devan Goodwin 2013-08-06 12:03:02 EDT
Unfortunately I think we have to close this as a cantfix.

The FV guest is showing *no* dmi facts in "subscription-manager facts --list", this is where we get the guest UUID. This is very likely caused by:

[root@localhost ~]# dmidecode                   
# dmidecode 2.11
/sys/firmware/efi/systab: SMBIOS entry point missing

Searching for that error turns up bugs like:

https://bugzilla.redhat.com/show_bug.cgi?id=497837

https://bugzilla.redhat.com/show_bug.cgi?id=473418

Unfortunately it looks like there is no way for us to fix this.
Comment 8 gaoshang 2013-08-07 03:06:23 EDT
Hi all, if this bug can not be fixed, bonus pool can not be created on FV guest, virt-who test on ia64(XEN) + FV will be blocked, that means host/guest association will not support FV guest on ia64 XEN hypervisor.

So I reopened this bug and hope somebody can confirm it, or find other ways to make virt-who test works, thanks!
Comment 9 Bryan Kearney 2013-08-07 08:57:25 EDT
Looknig at the earlier bugs, I do not think we can do anything here. I am going to close and let the business know.

Note You need to log in before you can comment on or make changes to this bug.