Bug 990548 - After Rebalance , with non root user, permissions on some link files change
After Rebalance , with non root user, permissions on some link files change
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: shishir gowda
senaik
: Reopened
Depends On: 904919
Blocks: 990154
  Show dependency treegraph
 
Reported: 2013-07-31 08:42 EDT by senaik
Modified: 2015-09-01 08:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 904919
Environment:
Last Closed: 2013-09-23 18:29:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 senaik 2013-08-08 04:41:06 EDT
Verified in Version : 3.4.0.18rhs-1.el6rhs.x86_64
===================

Repeated the steps as mentioned in 'Steps to Reproduce' , link files do not change permission to 'root' after rebalance . 

ll on the mount point after rebalance : 

lrwxrwxrwx. 1 ABC ABC    1 Aug  8 12:54 link1 -> 1
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:56 link10 -> 10
lrwxrwxrwx. 1 ABC ABC    3 Aug  8 12:54 link100 -> 100
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:56 link11 -> 11
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 10:32 link12 -> 12
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 10:31 link13 -> 13
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 10:32 link14 -> 14
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:54 link15 -> 15
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:54 link16 -> 16
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:54 link17 -> 17
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:56 link18 -> 18
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 10:32 link19 -> 19
lrwxrwxrwx. 1 ABC ABC    1 Aug  8 12:56 link2 -> 2
lrwxrwxrwx. 1 ABC ABC    2 Aug  8 12:56 link20 -> 20
.
.
Comment 4 Scott Haines 2013-09-23 18:29:52 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.