Bug 990602 - FTBFS: b/c mongodb boost dependency is old
FTBFS: b/c mongodb boost dependency is old
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mongodb (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Troy Dawson
Fedora Extras Quality Assurance
:
Depends On: 979687 990617
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:10 EDT by Timothy St. Clair
Modified: 2013-08-12 15:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 15:33:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy St. Clair 2013-07-31 10:10:06 EDT
Building my package(condor) which uses libmongodb, yields a mock error: 

Error: Package: libmongodb-2.4.5-4.fc20.i686 (build)
           Requires: libboost_system-mt.so.1.53.0
Error: Package: libmongodb-2.4.5-4.fc20.i686 (build)
           Requires: libboost_thread-mt.so.1.53.0
Error: Package: libmongodb-2.4.5-4.fc20.i686 (build)
           Requires: libboost_filesystem-mt.so.1.53.0

current rawhide == boost-1.54.0-2.fc20
Comment 1 Troy Dawson 2013-07-31 10:53:19 EDT
We have attempted to rebuilt mongodb for the new boost without success.  It is failling with the new arm build (even though it can build on the older arm-koji build) due to the new gperftools not building on arm.
Comment 2 Troy Dawson 2013-08-12 15:33:17 EDT
gperftools was fixed and put into rawhide.  We have now rebuilt mongodb, fixing this bug.

Note You need to log in before you can comment on or make changes to this bug.