Bug 990728 - Refresh Manifest fails when the upstream distributor has all the subscriptions removed
Refresh Manifest fails when the upstream distributor has all the subscription...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: 1.3
Assigned To: William Poteat
Tazim Kolhar
:
Depends On: 998010
Blocks: sam13-tracker 997155
  Show dependency treegraph
 
Reported: 2013-07-31 17:03 EDT by sthirugn@redhat.com
Modified: 2016-04-25 20:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 997155 (view as bug list)
Environment:
Last Closed: 2013-10-01 07:15:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Manifest refresh for custom distributor (72.98 KB, image/png)
2013-08-19 03:45 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-07-31 17:03:59 EDT
Description of problem:
Refresh Manifest fails when the upstream distributor has all the subscriptions removed

Version-Release number of selected component (if applicable):
* candlepin-0.8.18-1.el6.noarch
* candlepin-cert-consumer-tyan-gt24-12.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.18-1.el6.noarch
* candlepin-tomcat6-0.8.18-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
* katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
* katello-common-1.4.2-1.git.997.e699743.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.997.e699743.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.997.e699743.el6.noarch
* katello-headpin-1.4.2-1.git.997.e699743.el6.noarch
* katello-headpin-all-1.4.2-1.git.997.e699743.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Create a distributor in portal.  Attach few subscriptions. Download the manifest
2. Log in to katello UI and upload the manifest from step 1
3. Go back to portal and remove all the attached subscriptions
4. Refresh the manifest in katello by clicking 'Refresh Manifest' button on the Subscriptions page

Actual results:
Refresh is successful but all the subscriptions were still displayed

Expected results:
Refresh is successful and all the subscriptions gone


Additional info:
Comment 1 Bryan Kearney 2013-08-08 15:49:03 EDT
Fixed in master at:

Author: William Poteat <wpoteat@redhat.com>
Date:   Fri Aug 2 13:17:47 2013 -0400

    990728: Refresh Manifest fails when the upstream distributor has all the subscriptions removed
    
    As the manifest is the entirety of the definition of the distributor, if the
    manifest update contains no entitlements, then the distributor must lose
    all of its subscriptions.

Please verify with 0.8.20 or later.
Comment 3 Tazim Kolhar 2013-08-19 03:45:25 EDT
Created attachment 787913 [details]
Manifest refresh for custom distributor

VERIFIED:

# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-common-1.4.3-7.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.4-2.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
katello-cli-1.4.3-7.el6sat.noarch
katello-common-1.4.3-8.el6sam_splice.noarch
katello-headpin-1.4.3-8.el6sam_splice.noarch
katello-headpin-all-1.4.3-8.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
Comment 5 errata-xmlrpc 2013-10-01 07:15:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.