Bug 997155 - Refresh Manifest fails when the upstream distributor has all the subscriptions removed
Refresh Manifest fails when the upstream distributor has all the subscription...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: candlepin-bugs
sthirugn@redhat.com
: Triaged
Depends On: 990728
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 15:25 EDT by Bryan Kearney
Modified: 2014-07-02 10:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 990728
Environment:
Last Closed: 2014-07-02 10:09:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2013-08-14 15:25:45 EDT
+++ This bug was initially created as a clone of Bug #990728 +++

Description of problem:
Refresh Manifest fails when the upstream distributor has all the subscriptions removed

Version-Release number of selected component (if applicable):
* candlepin-0.8.18-1.el6.noarch
* candlepin-cert-consumer-tyan-gt24-12.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.18-1.el6.noarch
* candlepin-tomcat6-0.8.18-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.137.fea0d84.el6.noarch
* katello-cli-common-1.4.2-1.git.137.fea0d84.el6.noarch
* katello-common-1.4.2-1.git.997.e699743.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.997.e699743.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.997.e699743.el6.noarch
* katello-headpin-1.4.2-1.git.997.e699743.el6.noarch
* katello-headpin-all-1.4.2-1.git.997.e699743.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Create a distributor in portal.  Attach few subscriptions. Download the manifest
2. Log in to katello UI and upload the manifest from step 1
3. Go back to portal and remove all the attached subscriptions
4. Refresh the manifest in katello by clicking 'Refresh Manifest' button on the Subscriptions page

Actual results:
Refresh is successful but all the subscriptions were still displayed

Expected results:
Refresh is successful and all the subscriptions gone


Additional info:

--- Additional comment from Bryan Kearney on 2013-08-08 15:49:03 EDT ---

Fixed in master at:

Author: William Poteat <wpoteat@redhat.com>
Date:   Fri Aug 2 13:17:47 2013 -0400

    990728: Refresh Manifest fails when the upstream distributor has all the subscriptions removed
    
    As the manifest is the entirety of the definition of the distributor, if the
    manifest update contains no entitlements, then the distributor must lose
    all of its subscriptions.

Please verify with 0.8.20 or later.
Comment 1 RHEL Product and Program Management 2013-09-17 00:18:20 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Mike McCune 2013-10-17 17:04:51 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 7 sthirugn@redhat.com 2014-05-07 12:02:52 EDT
Verified.

Version Tested:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.5.0.22-1.el6sat.noarch
* foreman-compute-1.5.0.22-1.el6sat.noarch
* foreman-gce-1.5.0.22-1.el6sat.noarch
* foreman-libvirt-1.5.0.22-1.el6sat.noarch
* foreman-ovirt-1.5.0.22-1.el6sat.noarch
* foreman-postgresql-1.5.0.22-1.el6sat.noarch
* foreman-proxy-1.5.7-1.el6sat.noarch
* foreman-selinux-1.5.0-0.develop.el6sat.noarch
* foreman-vmware-1.5.0.22-1.el6sat.noarch
* katello-1.5.0-20.el6sat.noarch
* katello-apache-1.0-1.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.34-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* openldap-devel-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
* pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
* pulp-server-2.3.1-0.4.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
Comment 8 Bryan Kearney 2014-07-02 10:09:20 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0
Comment 9 Bryan Kearney 2014-07-02 10:09:20 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.