Bug 990830 - Use volume op-version instead of cluster op-version to auto enable open-behind in volgen
Use volume op-version instead of cluster op-version to auto enable open-behin...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks: 990958
  Show dependency treegraph
 
Reported: 2013-08-01 01:24 EDT by Kaushal
Modified: 2014-04-17 07:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990958 (view as bug list)
Environment:
Last Closed: 2014-04-17 07:45:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushal 2013-08-01 01:24:38 EDT
The volgen should use the volume op-versions instead of cluster op-version to enable features.
Comment 1 Anand Avati 2013-08-01 01:39:58 EDT
REVIEW: http://review.gluster.org/5385 (glusterd: Use volume op-versions during volgen) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)
Comment 2 Anand Avati 2013-08-02 05:29:25 EDT
COMMIT: http://review.gluster.org/5385 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 3af61d6758bc41e7c461d9d54f0caf872870329c
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Jul 24 18:34:38 2013 +0530

    glusterd: Use volume op-versions during volgen
    
    Instead of using the cluster op-version, volume op-version is used to
    enable open-behind during volgen. For doing this, the volume op-versions
    are updated before regenerating the volfiles.
    
    Change-Id: I675bb549bf7c7c0279030dca698fb530781addc6
    BUG: 990830
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5385
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Anand Avati 2013-09-06 04:42:40 EDT
REVIEW: http://review.gluster.org/5831 (glusterd: Use volume op-versions during volgen) posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 4 Anand Avati 2013-09-13 03:20:52 EDT
REVIEW: http://review.gluster.org/5831 (glusterd: Use volume op-versions during volgen) posted (#2) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 5 Anand Avati 2013-09-13 15:12:20 EDT
COMMIT: http://review.gluster.org/5831 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 67b0e817720eb95aee706a11fdf4633607aacd82
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Jul 24 18:34:38 2013 +0530

    glusterd: Use volume op-versions during volgen
    
      Backport of '3af61d6 glusterd: Use volume op-versions during volgen'
      from master
    
    Instead of using the cluster op-version, volume op-version is used to
    enable open-behind during volgen. For doing this, the volume op-versions
    are updated before regenerating the volfiles.
    
    BUG: 990830
    Change-Id: I07e4a34004816c803fcbb3ee1ddd4b1e4c3a8006
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5831
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:45:04 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.