Bug 990925 - java-1.7.0-openjdk not found by system-switch-java
java-1.7.0-openjdk not found by system-switch-java
Status: CLOSED DUPLICATE of bug 1020005
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Omair Majid
Fedora Extras Quality Assurance
:
: 990941 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 04:36 EDT by Petr Viktorin
Modified: 2014-02-04 11:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-04 11:56:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Viktorin 2013-08-01 04:36:25 EDT
Description of problem:
java-1.7.0-openjdk is not found by system-switch-java

Version-Release number of selected component (if applicable):
$ rpm -q java-1.7.0-openjdk system-switch-java
java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64
system-switch-java-1.1.5-6.fc19.noarch


Steps to Reproduce:
1. Install a minimal Fedora 19 system
2. sudo yum install java-1.7.0-openjdk /usr/bin/system-switch-java
3. sudo system-switch-java

Actual results:

┌───────┤ Java Toolset Configuration ├────────┐
│                                             │ 
│ No supported Java packages were found.  A   │ 
│ supported Java package is one that installs │ 
│ a file of the form:                         │ 
│                                             │ 
│ /usr/lib/jvm/jre-$version-$vendor/bin/java  │ 
│                                             │ 
│ For example, java-1.4.2-gcj-compat is a     │ 
│ supported package because it installs:      │ 
│                                             │ 
│ /usr/lib/jvm/jre-1.4.2-gcj/bin/java         │ 
│                                             │ 
│                   ┌────┐                    │ 
│                   │ OK │                    │ 
│                   └────┘                    │ 
│                                             │ 
│                                             │ 
└─────────────────────────────────────────────┘ 


Expected results:
openjdk-1.7.0 appears in the list


Additional info:
It seems that some other Java package fixes the problem, but I haven't identified which one. Please use a minimal system to reproduce.
Comment 1 Omair Majid 2013-08-05 12:26:41 EDT
So system-switch-java is looking for /usr/lib/jvm/jre-1.7.0-openjdk but the latest F19 has /usr/lib/jvm/jre-1.7.0_openjdk.

That "_openjdk" at the end should be "-openjdk". I will prepare a fix.
Comment 2 Omair Majid 2013-08-07 11:49:59 EDT
*** Bug 990941 has been marked as a duplicate of this bug. ***
Comment 3 Omair Majid 2013-10-17 17:44:35 EDT
Jiri was kind enough to fix _openjdk to -openjdk. Now we are hitting bug 1020005.
Comment 4 Omair Majid 2014-02-04 11:56:34 EST

*** This bug has been marked as a duplicate of bug 1020005 ***

Note You need to log in before you can comment on or make changes to this bug.