Bug 990941 - Doesn't recognize new layout of java-1.7.0-openjdk
Doesn't recognize new layout of java-1.7.0-openjdk
Status: CLOSED DUPLICATE of bug 990925
Product: Fedora
Classification: Fedora
Component: system-switch-java (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Omair Majid
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 05:09 EDT by Alexander Kurtakov
Modified: 2013-08-07 11:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 11:49:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Kurtakov 2013-08-01 05:09:32 EDT
On startup: 
No supported Java packages were found.  A supported Java package is one that installs a file of the form:

/usr/lib/jvm/jre-$version-$vendor/bin/java

For example, java-1.4.2-gcj-compat is a supported package because it installs:

/usr/lib/jvm/jre-1.4.2-gcj/bin/java

This happens even if java-1.7.0-openjdk is installed. Note that java-1.8.0-openjdk is properly recognized. I do understand the simplification of jvm packages but system-switch-java is especially useful with the possibility to have multiple 1.7 and the ability to test 1.8. Without system-switch-java it's too easy to come with weird combination if one tried to set up alternatives manually.
Comment 1 Omair Majid 2013-08-07 11:49:59 EDT

*** This bug has been marked as a duplicate of bug 990925 ***

Note You need to log in before you can comment on or make changes to this bug.