Bug 990938 - [RHEVM][TEXT] improve error message displayed in GUI when obtaining IP from DHCP fails
[RHEVM][TEXT] improve error message displayed in GUI when obtaining IP from D...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
low Severity low
: ---
: 3.3.0
Assigned To: Moti Asayag
Martin Pavlik
network
:
: 1001090 (view as bug list)
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-08-01 05:05 EDT by Martin Pavlik
Modified: 2016-02-10 14:55 EST (History)
9 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (9.42 MB, application/x-xz)
2013-08-01 05:05 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19111 None None None Never

  None (edit)
Description Martin Pavlik 2013-08-01 05:05:08 EDT
Created attachment 781485 [details]
log_collector

Description of problem:

When obtaining IP from DHCP fails, reason is clearly mentioned in engine.log

Failed to SetupNetworksVDS, error = Determining IP information for VLAN170... 
failed.

but GUI show just "Error while executing action Setup Networks: Unexpected exception"

it would be helpful for the users to get clear explanation what went wrong.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.11.master.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. create logical network and attach it to host
2. specify that network should obtain IP from DHCP (while there is no DHCP on the network)


Actual results:
"Error while executing action Setup Networks: Unexpected exception"

Expected results:
"Error while executing action Setup Networks: Determining IP information for VLAN170... failed."

Additional info:

2013-08-01 09:57:59,459 ERROR [org.ovirt.engine.core.bll.network.host.SetupNetworksCommand] (ajp-/127.0.0.1:8702-8) Command org.ovirt.engine.core.bll.network.host.SetupNetworksCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to SetupNetworksVDS, error = Determining IP information for VLAN170... failed. (Failed with VDSM error unexpected and code 16)
Comment 1 Moti Asayag 2013-09-09 11:35:37 EDT
The relevant piece from vdsm.log is the following which indicates VDSM has a specific error code 29 which doesn't appear on engine.

Thread-101586::ERROR::2013-08-01 10:56:26,890::API::1261::vds::(setupNetworks) Determining IP information for VLAN170... failed.
Traceback (most recent call last):
  File "/usr/share/vdsm/API.py", line 1259, in setupNetworks
    supervdsm.getProxy().setupNetworks(networks, bondings, options)
  File "/usr/share/vdsm/supervdsm.py", line 50, in __call__
    return callMethod()
  File "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>
    **kwargs)
  File "<string>", line 2, in setupNetworks
  File "/usr/lib64/python2.6/multiprocessing/managers.py", line 740, in _callmethod
    raise convert_to_error(kind, result)
ConfigNetworkError: (29, 'Determining IP information for VLAN170... failed.')

However, code 29 ERR_FAILED_IFUP serves multiple errors raised by vdsm and not a specific one. The engine has a static mapping of VDSM errors, therefore I don't think that a generic message of "Failed to bring interface up" without an interface name in SetupNetwork action which serves multiple actions will reveal enough information and will reduce the need of the user to look at the logs.

I'll add the generic IFUP failure message so it can be used by other commands to which it might be relevant (e.g. addNetwork).
Comment 2 Martin Pavlik 2013-09-18 09:57:12 EDT
verified on is 15

gui provides 
Error while executing action Setup Networks: Failed to bring interface up

and vdsm log

error = Determining IP information for no_dhcp... failed.
Comment 3 Moti Asayag 2013-09-29 06:54:05 EDT
*** Bug 1001090 has been marked as a duplicate of this bug. ***
Comment 4 Itamar Heim 2014-01-21 17:32:58 EST
Closing - RHEV 3.3 Released
Comment 5 Itamar Heim 2014-01-21 17:33:04 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.