Bug 990965 - Report error when configure network with static IPv4 mode
Report error when configure network with static IPv4 mode
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 06:04 EDT by haiyang,dong
Modified: 2014-01-21 14:47 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:47:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-08-01 06:04:22 EDT
Description of problem:
It reports "An error appeared in the UI: < InvalidData 'The field must contain a valid IPv4 address or an empty string.'>" when configure network with static IPv4 mode.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh6.5.
2. Select a NIC and configure it with IPv4 Static mode.
   Bootprotocol :   ( ) Disabled   ( ) Auto     ( ) DHCP      (X) Static
   IP Address   :   10.66.8.136           Netmask :       32
   Gateway      :   10.66.11.254

Actual results:
1. After step2, it reports "An error appeared in the UI: < InvalidData 'The field must contain a valid IPv4 address or an empty string.'> ".

Expected results:
1. After step2, it can set ipv4 address with static mode successfully.

Additional info:
Comment 2 Mike Burns 2013-08-15 09:21:18 EDT
may be related to bug 990984
Comment 3 Fabian Deutsch 2013-09-11 05:34:22 EDT
Tested as follows:

1. Apply patch
2. Run in dev mode:
   PYTHONPATH=src/ scripts/ovirt-node-setup --dry --defaults /tmp/cfg_dummy
3. Configure NIC
4. Enter
   IP: 1.2.3.4
   Netmask: 32
5. Error is shown, <Save> is disabled

6. Enter
   IP: 1.2.3.4
   Netmask: 2.3.4.5
   Gateway: 3.4.5.6
<Save> is enabled and save does not raise an error.
Comment 6 haiyang,dong 2013-10-18 00:22:28 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

It still reports "An error appeared in the UI: < InvalidData 'The field must contain a valid IPv4 address or an empty string.'>" when setting netmask of ipv4 settings as Prefix Length.
So need re-assigned this bug again.
Comment 10 haiyang,dong 2013-10-31 05:18:29 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

Now the item of Netmask only accept "a valid IPv4 address or an empty string",
also when input a valid IPv4 address or an empty string and apply it, no exception error was thrown. 

so this bug has been fixed, change it into "VERIFIED".
Comment 13 Cheryn Tan 2013-11-07 19:34:46 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 15 errata-xmlrpc 2014-01-21 14:47:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.