Bug 990985 - shutdown/reboot VM causes an exception on removeVmFromMonitoredDomains
shutdown/reboot VM causes an exception on removeVmFromMonitoredDomains
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity urgent
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Aharon Canan
storage
: Regression, TestBlocker
: 994551 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 06:48 EDT by Michal Skrivanek
Modified: 2016-02-10 12:25 EST (History)
11 users (show)

See Also:
Fixed In Version: is9.1
Doc Type: Bug Fix
Doc Text:
A previous commit to automatically unpause virtual machines when a storage domain became active unexpectedly caused an exception on removeVmFromMonitoredDomains during virtual machine shutdown. Now, the list of virtual machine domains is maintained inside the virtual machine object, so virtual machines can be powered off without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:29:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
abaron: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17664 None None None Never

  None (edit)
Description Michal Skrivanek 2013-08-01 06:48:00 EDT
commit I0f88ebcab07dea20a0288f6b75c5888a74d9e440 (feature "automatically unpause vms in EIO when SD becomes active") broke vdsm on VM shutdown

error looks like:

libvirtEventLoop::INFO::2013-08-01 01:09:30,866::vm::4214::vm.Vm::(releaseVm) vmId=`3b98c785-b090-4b09-aca9-32f779ca4034`::Release VM resources
libvirtEventLoop::DEBUG::2013-08-01 01:09:30,867::sampling::292::vm.Vm::(stop) vmId=`3b98c785-b090-4b09-aca9-32f779ca4034`::Stop statistics collection
Thread-408::ERROR::2013-08-01 01:09:30,865::BindingXMLRPC::998::vds::(wrapper) unexpected error
Traceback (most recent call last):
 File "/usr/share/vdsm/BindingXMLRPC.py", line 984, in wrapper
   res = f(*args, **kwargs)
 File "/usr/share/vdsm/BindingXMLRPC.py", line 211, in vmDestroy
   return vm.destroy()
 File "/usr/share/vdsm/API.py", line 322, in destroy
   res = v.destroy()
 File "/usr/share/vdsm/vm.py", line 4278, in destroy
   response = self.releaseVm()
 File "/usr/share/vdsm/vm.py", line 4246, in releaseVm
   self.cif.removeVmFromMonitoredDomains(self.id)
 File "/usr/share/vdsm/clientIF.py", line 125, in removeVmFromMonitoredDomains
   for dom in self.domainVmIds:
RuntimeError: dictionary changed size during iteration
Comment 1 Jay Turner 2013-08-01 07:59:29 EDT
Setting Target Milestone Beta1.
Comment 2 Vinzenz Feenstra [evilissimo] 2013-08-08 04:11:47 EDT
*** Bug 994551 has been marked as a duplicate of this bug. ***
Comment 3 Aharon Canan 2013-08-15 08:02:01 EDT
verified using is10 

Now we can poweroff VM without any problems.
Comment 4 Charlie 2013-11-27 19:27:02 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 5 errata-xmlrpc 2014-01-21 11:29:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.