Bug 994551 - Stop VM is throwing an error Failed to power off VM
Stop VM is throwing an error Failed to power off VM
Status: CLOSED DUPLICATE of bug 990985
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Roy Golan
Tareq Alayan
: Regression, TestBlocker, Triaged
: 994874 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2013-08-07 09:39 EDT by Ohad Basan
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-08 04:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
vdsm log (5.59 MB, text/x-log)
2013-08-07 09:40 EDT, Ohad Basan
no flags Details

  None (edit)
Description Ohad Basan 2013-08-07 09:39:01 EDT
Description of problem:

VM eventually stops but the engine is throwing an error along before stopping it and an exception shows up on vdsm

2013-08-07 16:26:29,342 ERROR [org.ovirt.engine.core.bll.StopVmCommand] (pool-5-thread-47) Command org.ovirt.engine.core.bll.StopVmCommand throw Vdc Bll exception. With error message VdcBLLException: org.ovirt.e
ngine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to DestroyVDS, error = Unexpected exception (Failed with error unexpected and code 16)

Thread-748::DEBUG::2013-08-07 16:26:32,512::task::974::TaskManager.Task::(_decref) Task=`f772a895-9609-46b5-85f8-904f1fee475e`::ref 0 aborting False
libvirtEventLoop::INFO::2013-08-07 16:26:32,512::vm::4217::vm.Vm::(releaseVm) vmId=`4af7679b-ae25-4dca-81e5-8b22e3e5c417`::Release VM resources
Thread-748::ERROR::2013-08-07 16:26:32,512::BindingXMLRPC::993::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 979, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/BindingXMLRPC.py", line 211, in vmDestroy
    return vm.destroy()
  File "/usr/share/vdsm/API.py", line 322, in destroy
    res = v.destroy()
  File "/usr/share/vdsm/vm.py", line 4281, in destroy
    response = self.releaseVm()
  File "/usr/share/vdsm/vm.py", line 4249, in releaseVm
  File "/usr/share/vdsm/clientIF.py", line 125, in removeVmFromMonitoredDomains
    for dom in self.domainVmIds:
RuntimeError: dictionary changed size during iteration
libvirtEventLoop::DEBUG::2013-08-07 16:26:32,514::sampling::292::vm.Vm::(stop) vmId=`4af7679b-ae25-4dca-81e5-8b22e3e5c417`::Stop statistics collection
libvirtEventLoop::DEBUG::2013-08-07 16:26:32,519::libvirtconnection::101::libvirtconnection::(wrapper) Unknown libvirterror: ecode: 42 edom: 10 level: 2 message: Domain not found: no domain with matching uuid '4
Comment 2 Ohad Basan 2013-08-07 09:40:27 EDT
Created attachment 783919 [details]
vdsm log
Comment 7 Haim 2013-08-08 03:40:00 EDT
*** Bug 994874 has been marked as a duplicate of this bug. ***
Comment 9 Vinzenz Feenstra [evilissimo] 2013-08-08 04:11:47 EDT
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=990985

*** This bug has been marked as a duplicate of bug 990985 ***

Note You need to log in before you can comment on or make changes to this bug.