Bug 99115 - redhat-config-users and useradd allowed user names not consistant
redhat-config-users and useradd allowed user names not consistant
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
: 101664 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-14 14:36 EDT by Pete Norton
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 21:26:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Norton 2003-07-14 14:36:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
redhat-config-users wholesale does not allow any punctuation in a user name. 
However, useradd (from shadow-util) does allow the use of the dash ('-') and the
underscore ('_').  Adding a user with useradd with a dash or an underscore makes
that user effectively un-editable with redhat-config-users.

Since both utilities do pretty much the same thing, they need to be consistant
in what kind of user names they allow.

My biggest gripe right now is that from previous versions of Redhat to v9.0, the
ability to use a period ('.') in a user name as been removed.  I assume that
this is deliberate, but I can not find any offical pronouncement of what makes a
"legal" username.

Version-Release number of selected component (if applicable):
redhat-config-users-1.1.5-7

How reproducible:
Always

Steps to Reproduce:
1.useradd joe-smith
2.Edit user joe-smith with User Manger
3.Make a change and try to save.
    

Actual Results:  The user name 'joe-smith' contains punctuation characters. 
Please do not use punctuation in the user name.

Expected Results:  It should accept the changes?

Additional info:
Comment 1 Brent Fox 2003-08-14 21:26:30 EDT
Ok, I've changed it to allow underscores and dashes in both usernames and
groupnames.  I will have to fix this in firstboot as well.  Should be fixed in
redhat-config-users-1.1.16-1.
Comment 2 Brent Fox 2003-08-15 13:42:45 EDT
*** Bug 101664 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Miller 2004-04-15 13:23:25 EDT
This fix is broken. :)

See bug #120669.

Note You need to log in before you can comment on or make changes to this bug.