Bug 991202 - Excessive warnings of invalid metric calls
Excessive warnings of invalid metric calls
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.2
Unspecified Unspecified
medium Severity medium
: ER02
: JON 3.2.0
Assigned To: Thomas Segismont
Mike Foley
:
: 991203 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 15:59 EDT by Viet Nguyen
Modified: 2014-01-02 15:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:43:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
agent.log.zip (81.13 KB, application/zip)
2013-08-01 15:59 EDT, Viet Nguyen
no flags Details

  None (edit)
Description Viet Nguyen 2013-08-01 15:59:54 EDT
Created attachment 781741 [details]
agent.log.zip

Description of problem:

1.  I ran the following sql statement to increase metric collection intervals

UPDATE
	rhq_measurement_def 
SET
	default_interval=30000,
	default_on=true
WHERE
	category=1

2. Imported 40 EAP 6 instances.

3. I'm seeing about 10 Warnings per second in agent.log.  See attachment for full log.

2013-08-01 14:20:49,479 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: subsystem=jgroups,stack=udp,transport=TRANSPORT}, additionalProperties={name=socket-binding}} - response body was [{"outcome" : "failed", "failure-description" : "JBAS014739: No handler for read-attribute at address [\n    (\"subsystem\" => \"jgroups\"),\n    (\"stack\" => \"udp\"),\n    (\"transport\" => \"TRANSPORT\")\n]", "rolled-back" : true}].
2013-08-01 14:20:49,563 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: subsystem=jgroups,stack=udp,transport=TRANSPORT}, additionalProperties={name=socket-binding}} - response body was [{"outcome" : "failed", "failure-description" : "JBAS014739: No handler for read-attribute at address [\n    (\"subsystem\" => \"jgroups\"),\n    (\"stack\" => \"udp\"),\n    (\"transport\" => \"TRANSPORT\")\n]", "rolled-back" : true}].
2013-08-01 14:20:49,672 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: subsystem=jgroups,stack=udp,transport=TRANSPORT}, additionalProperties={name=socket-binding}} - response body was [{"outcome" : "failed", "failure-description" : "JBAS014739: No handler for read-attribute at address [\n    (\"subsystem\" => \"jgroups\"),\n    (\"stack\" => \"udp\"),\n    (\"transport\" => \"TRANSPORT\")\n]", "rolled-back" : true}].
2013-08-01 14:20:49,775 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}, additionalProperties={name=usage-threshold-exceeded}} - response body was [{"outcome" : "failed", "result" : null, "failure-description" : "java.lang.UnsupportedOperationException: Usage threshold is not supported", "rolled-back" : true}].
2013-08-01 14:20:49,775 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.BaseComponent)- Getting metric [usage-threshold-exceeded] at [ Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}] failed: java.lang.UnsupportedOperationException: Usage threshold is not supported, rolled-back=true
2013-08-01 14:20:49,833 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: core-service=platform-mbean,type=memory-pool,name=Code_Cache}, additionalProperties={name=collection-usage-threshold-exceeded}} - response body was [{"outcome" : "failed", "result" : null, "failure-description" : "java.lang.UnsupportedOperationException: CollectionUsage threshold is not supported", "rolled-back" : true}].


Version-Release number of selected component (if applicable):
Version: 3.2.0.ALPHA_QA
Build Number: edb3aa6:6964581
Comment 1 Heiko W. Rupp 2013-08-23 10:42:25 EDT
*** Bug 991203 has been marked as a duplicate of this bug. ***
Comment 2 Heiko W. Rupp 2013-08-23 11:31:03 EDT
I agree that those are annoying, but the real bad guy is EAP here, who is not able to send a 500 for real issues and a 404 for not found.

We need to tone those messages down, by looking at the internal AS code like ( JBAS014739 ) and suppress those in logging (or only log at debug level).

Actually there is code for this, which we need to fix.
Comment 3 Thomas Segismont 2013-09-20 08:26:07 EDT
Fixed in master

commit a9b580eecbbbd58fc46dac0c177fdf15a28808c5
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Fri Sep 20 13:58:08 2013 +0200
    
Added another JBASXXXXX pattern to the list of unknown resource response patterns
Made ASConnection log infos and warnings only in verbose mode
Comment 4 Viet Nguyen 2013-12-06 17:18:00 EST
I'm still seeing a lot of "Usage threshold not support" warnings

----
2013-12-06 17:11:58,811 WARN  [ResourceContainer.invoker.daemon-25] (rhq.modules.plugins.jbossas7.BaseComponent)- Getting metric [usage-threshold-count] at [ Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}] failed: java.lang.UnsupportedOperationException: Usage threshold is not supported, rolled-back=true

2013-12-06 17:11:59,622 WARN  [ResourceContainer.invoker.daemon-25] (rhq.modules.plugins.jbossas7.BaseComponent)- Non numeric input for [collection-usage-threshold-exceeded] : [false]

2013-12-06 17:11:59,624 WARN  [ResourceContainer.invoker.daemon-25] (rhq.modules.plugins.jbossas7.BaseComponent)- Getting metric [usage-threshold-count] at [ Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}] failed: java.lang.UnsupportedOperationException: Usage threshold is not supported, rolled-back=true
2013-12-06 17:11:59,674 WARN  [ResourceContainer.invoker.daemon-25] (rhq.modules.plugins.jbossas7.BaseComponent)- Getting metric [usage-threshold-exceeded] at [ Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}] failed: java.lang.UnsupportedOperationException: Usage threshold is not supported, rolled-back=true
2013-12-06 17:11:59,689 WARN  [ResourceContainer.invoker.daemon-25] (rhq.modules.plugins.jbossas7.BaseComponent)- Getting metric [usage-threshold-count] at [ Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Eden_Space}] failed: java.lang.UnsupportedOperationException: Usage threshold is not supported, rolled-back=true
2013-12-06 17:11:59,754 WARN  [ResourceContainer.invoker.daemon-25] (rhq.modules.plugins.jbossas7.BaseComponent)- Non numeric input for [collection-usage-threshold-exceeded] : [false]
Comment 5 Thomas Segismont 2013-12-10 10:06:34 EST
(In reply to Viet Nguyen from comment #4)
> I'm still seeing a lot of "Usage threshold not support" warnings

Fixed in master

commit 4ecca884ee72ed4698804f6b6df5fc5da9671734
Author: Thomas Segismont <tsegismo@redhat.com>
Date:   Tue Dec 10 16:02:27 2013 +0100

Fixed "*-exceeded" metrics dataType
Created new MemoryPoolComponent
    
Now gathering "usage-threshold-*" and "collection-usage-threshold-*" metrics only if enabled

Note You need to log in before you can comment on or make changes to this bug.