Bug 991203 - Excessive warnings of invalid metric calls
Excessive warnings of invalid metric calls
Status: CLOSED DUPLICATE of bug 991202
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6 (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 16:00 EDT by Viet Nguyen
Modified: 2013-08-23 10:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 10:42:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Viet Nguyen 2013-08-01 16:00:23 EDT
Description of problem:

1.  I ran the following sql statement to increase metric collection intervals

UPDATE
	rhq_measurement_def 
SET
	default_interval=30000,
	default_on=true
WHERE
	category=1

2. Imported 40 EAP 6 instances.

3. I'm seeing about 10 Warnings per second in agent.log.  See attachment for full log.

2013-08-01 14:20:49,479 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: subsystem=jgroups,stack=udp,transport=TRANSPORT}, additionalProperties={name=socket-binding}} - response body was [{"outcome" : "failed", "failure-description" : "JBAS014739: No handler for read-attribute at address [\n    (\"subsystem\" => \"jgroups\"),\n    (\"stack\" => \"udp\"),\n    (\"transport\" => \"TRANSPORT\")\n]", "rolled-back" : true}].
2013-08-01 14:20:49,563 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: subsystem=jgroups,stack=udp,transport=TRANSPORT}, additionalProperties={name=socket-binding}} - response body was [{"outcome" : "failed", "failure-description" : "JBAS014739: No handler for read-attribute at address [\n    (\"subsystem\" => \"jgroups\"),\n    (\"stack\" => \"udp\"),\n    (\"transport\" => \"TRANSPORT\")\n]", "rolled-back" : true}].
2013-08-01 14:20:49,672 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: subsystem=jgroups,stack=udp,transport=TRANSPORT}, additionalProperties={name=socket-binding}} - response body was [{"outcome" : "failed", "failure-description" : "JBAS014739: No handler for read-attribute at address [\n    (\"subsystem\" => \"jgroups\"),\n    (\"stack\" => \"udp\"),\n    (\"transport\" => \"TRANSPORT\")\n]", "rolled-back" : true}].
2013-08-01 14:20:49,775 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}, additionalProperties={name=usage-threshold-exceeded}} - response body was [{"outcome" : "failed", "result" : null, "failure-description" : "java.lang.UnsupportedOperationException: Usage threshold is not supported", "rolled-back" : true}].
2013-08-01 14:20:49,775 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.BaseComponent)- Getting metric [usage-threshold-exceeded] at [ Address{path: core-service=platform-mbean,type=memory-pool,name=PS_Survivor_Space}] failed: java.lang.UnsupportedOperationException: Usage threshold is not supported, rolled-back=true
2013-08-01 14:20:49,833 WARN  [ResourceContainer.invoker.daemon-96] (rhq.modules.plugins.jbossas7.ASConnection)- Received 500 Internal Server Error response to Operation{operation='read-attribute', address=Address{path: core-service=platform-mbean,type=memory-pool,name=Code_Cache}, additionalProperties={name=collection-usage-threshold-exceeded}} - response body was [{"outcome" : "failed", "result" : null, "failure-description" : "java.lang.UnsupportedOperationException: CollectionUsage threshold is not supported", "rolled-back" : true}].


Version-Release number of selected component (if applicable):
Version: 3.2.0.ALPHA_QA
Build Number: edb3aa6:6964581
Comment 1 Heiko W. Rupp 2013-08-23 10:42:24 EDT

*** This bug has been marked as a duplicate of bug 991202 ***

Note You need to log in before you can comment on or make changes to this bug.