Bug 991253 - Add topic to configure EAP as a service on Microsoft Windows Server
Add topic to configure EAP as a service on Microsoft Windows Server
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: GA
: EAP 6.2.0
Assigned To: Lucas Costi
Russell Dickenson
:
: 834255 (view as bug list)
Depends On: 1006346
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 21:28 EDT by Lucas Costi
Modified: 2014-08-14 11:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:12:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucas Costi 2013-08-01 21:28:04 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=960560 which fixes this issue (Comment 9)

There is now a process to run an EAP server instance as a service for Microsoft Windows Server.

I will be resurrecting and revamping the previous topic for this (topic 3757)
Comment 1 Jan Stefl 2013-08-06 02:37:23 EDT
One thing missing in comment 9.
 - For successful service installation ("service install") you have to set env. variable JAVA_HOME properly.
Comment 2 Lucas Costi 2013-08-11 21:27:55 EDT
I am also amending the titles of the existing service topics to fix it from  "Configure JBoss EAP as a Service in..." to "Configure JBoss EAP 6 as a Service in..."

Topic 14102, new rev: 493933
Topic 3758, new rev: 493935
Topic 3757, new rev: 493936

Updated CS maps:

6.1.1 Install Guide [19232], new rev: 493940
6.2 Install Guide: [14873], new rev: 493943
Comment 4 Jan Stefl 2013-08-12 03:23:32 EDT
Lucas,
nice description of Win. service installation.

Just:
1. About 2. Extract the downloaded archive, and copy the na...
You can simply extract util package over the EAP installation - all files will be stored on right place.

2. About 4. Verify ...
Service is called "JBoss Enterprise Application Server 6.1" in a services list (after services.msc). But you are right, service name is really "EAP61SVC" (but it is only obvious if you click on the service - yeah, simply mess :-) ).
Comment 5 Lucas Costi 2013-08-12 22:02:07 EDT
Thanks Jan. Ah yes, there is the service 'name' vs. 'display name' distinction.  I have made suggested changes to the topic (3757, rev. 494463).
Comment 7 Jan Stefl 2013-08-15 03:31:34 EDT
Revision 1.0-53 verified -> OK
Comment 8 Lucas Costi 2013-08-20 23:35:40 EDT
I'm pulling the status of the docs change back to modified until a consensus can be reached regarding the implementation of the service in BZ#960560.

We have also temporarily removed the topics from the guide.
Comment 10 Lucas Costi 2013-09-29 21:59:13 EDT
QE will be implementing the GSS script from EAP 6.2 onwards as detailed in BZ#1006346.

The GSS script is detailed here https://access.redhat.com/site/solutions/183833

Vaclav, Tom: is QE and GSS happy for docs of the service install to be based on the procedure in the above customer portal solution?
Comment 12 Jan Stefl 2013-10-01 03:39:16 EDT
For QA: Agree with Tom and if the issue will be not fixed documentation should incorporate https://bugzilla.redhat.com/show_bug.cgi?id=1013660
Comment 13 Vaclav Tunka 2013-10-03 17:44:27 EDT
Lucas: I can speak for Engineering, not QE - Jan Stefl is your man. QE won't be maintaining the script. The script will be maintained by Tom Fonteyne from the GSS side, me in EAP distro + of course I am open to all patches & improvements that could be included to EAP. Otherwise I am fine with the procedure on customer portal.
Comment 16 Lucas Costi 2013-10-08 00:25:57 EDT
Thanks all!

I have revised topic 3757 with the updated content. Pending a brew on docstage for QA, the topic can be viewed here:

http://docbuilder.usersys.redhat.com/14873/#Install_JBoss_Enterprise_Application_Platform_6_Microsoft_Windows_Service
Comment 24 Jan Stefl 2013-10-11 07:21:48 EDT
Thanks,
It looks good, just add keyword "system" env. variable for JAVA_HOME.

The JAVA_HOME environment variable must be set.
->
The JAVA_HOME system environment variable must be set.
Comment 25 Lucas Costi 2013-10-13 19:48:20 EDT
Thanks Jan, fixed in topic 3757 rev 545844.

Waiting on a new docstage build for QA.
Comment 26 Petr Kremensky 2013-10-23 02:32:49 EDT
Looking good, but I would change two more things:
 - I would add the note into Procedure 4.16. that steps 2. Download the Native Utilities, and 3. Extract the archive may not be necessary once user choose to install the natives via installer
 - We should change the name of host variable from 'MASTER' to 'master' in step 4.B. Install service in Domain mode. Trying the whole procedure step by step with documentation I used "service.bat install /host MASTER /loglevel INFO" to install the service in Domain mode using default host, service start correctly, but stopping the service will fail with "The JBossEAP6 service could not be stopped." as "net stop JBossEAP6" command will use ./host=MASTER:shutdown
Comment 27 Lucas Costi 2013-10-23 21:09:21 EDT
Thanks Petr; changes made in topic 3757, rev 548583

Waiting on new build for QA.
Comment 29 Petr Kremensky 2013-10-24 02:25:38 EDT
Verified (during EAP 6.2.0.ER6 testing cycle).
Comment 31 Lucas Costi 2014-04-15 22:08:55 EDT
*** Bug 834255 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.