Bug 1006346 - Upgrade to common-daemons windows service management scripts supported by SEG/GSS
Upgrade to common-daemons windows service management scripts supported by SEG...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands (Show other bugs)
6.1.1
Unspecified Windows
high Severity high
: ER2
: EAP 6.2.0
Assigned To: Vaclav Tunka
Jan Stefl
Lucas Costi
: Improvement, ReleaseNotes
: 1006345 (view as bug list)
Depends On: JBPAPP6-1436 960560
Blocks: 991253
  Show dependency treegraph
 
Reported: 2013-09-10 09:20 EDT by Vaclav Tunka
Modified: 2013-10-16 05:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 05:58:23 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaclav Tunka 2013-09-10 09:20:14 EDT
Bug 960560 - Add service.bat and service.conf.bat was included into EAP 6.1.1. but not documented. After blocker only deadline we found out SEGs created a script of their own, which is better suited in Bug 900708 - (JBPAPP6-1436) Starting EAP as a service on Windows does not work with the startup scripts (standalone.bat/domain.bat).

The scripts are included in Bug 900708, but they were not tested by EAP QE, only by selected customers directly downloading these scripts from BZ.

We would like to get ACKs for this BZ, to be accepted for EAP 6.2.0. This script should replace scripts for commons-daemon based startup provided by QE in 960560.
Comment 1 Vaclav Tunka 2013-09-10 09:43:27 EDT
*** Bug 1006345 has been marked as a duplicate of this bug. ***
Comment 2 Vaclav Tunka 2013-09-17 12:21:11 EDT
This will be delivered in EAP 6.2.0 ER2. Paths are the same as per previous service script. This is version 6 by GSS/SEG numbering. Henceforth this will be maintained as part of EAP 6.2.0. Scripts are in the distgit repositories, but I recommend creating a new repository for this script either publicly with mirror on RH internal storage, or just the latter option.
Comment 3 Jan Stefl 2013-09-30 11:12:23 EDT
Verified in EAP 6.2.0.ER3
service.bat is part of EAP, but please check:
https://bugzilla.redhat.com/show_bug.cgi?id=1013660

Note You need to log in before you can comment on or make changes to this bug.