Bug 991327 - Environment variable error pops up when ssh to some old apps
Environment variable error pops up when ssh to some old apps
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On: 999013
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 03:21 EDT by Qiushui Zhang
Modified: 2015-05-14 19:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 10:22:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qiushui Zhang 2013-08-02 03:21:05 EDT
Description of problem:
When ssh to some old apps, error message pops up, saying like "bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier"

Version-Release number of selected component (if applicable):
stg(devenv-stage_435)
rhc 1.12.4

How reproducible:
always

Steps to Reproduce:
1. Prepare old apps. (We have reproduced the problem on apps created before July 16)
2. rhc ssh $appname
3. Check the ssh output message

Actual results:
Error message pops up, saying "bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier"

Expected results:
No such kind of error message

Additional info:
1. We have repoduced this issue on the following apps:
http://rb181-qiuzhang.stg.rhcloud.com
http://redmine-sprint25.stg.rhcloud.com
http://jbews2-bmeng1stg.stg.rhcloud.com
http://ruby19s-bmeng1stg.stg.rhcloud.com

2. Attach the output message here:
[openshift@dhcp-10-143 tmp]$ rhc ssh rb181
Connecting to 51e4ba8e2587c8be8b0000ef@rb181-qiuzhang.stg.rhcloud.com ...
bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier
bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier

    *********************************************************************

    You are accessing a service that is for use only by authorized users.  
    If you do not have authorization, discontinue use at once. 
    Any use of the services is subject to the applicable terms of the 
    agreement which can be found at: 
    https://www.openshift.com/legal

    *********************************************************************

    Welcome to OpenShift shell

    This shell will assist you in managing OpenShift applications.

    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!
    Shell access is quite powerful and it is possible for you to
    accidentally damage your application.  Proceed with care!
    If worse comes to worst, destroy your application with 'rhc app delete'
    and recreate it
    !!! IMPORTANT !!! IMPORTANT !!! IMPORTANT !!!

    Type "help" for more info.

[rb181-qiuzhang.stg.rhcloud.com 51e4ba8e2587c8be8b0000ef]\>
Comment 1 Dan Mace 2013-08-15 10:22:21 EDT
Going to close this one since it's not reproducible for new apps; if any prod apps have leftover ERBs causing this benign error, we'll have the gears cleaned up (as leftover ERBs would be indicative of some past bug/migration oversight/failure).

Delete any /var/lib/openshift/.../$cart/env/*.erb files in these stage apps to prevent the error message.

Note You need to log in before you can comment on or make changes to this bug.