Bug 999013 - Production Ruby app did not get migrated correctly
Production Ruby app did not get migrated correctly
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Paul Morie
libra bugs
: SupportQuestion
: 999667 (view as bug list)
Depends On:
Blocks: 991327
  Show dependency treegraph
 
Reported: 2013-08-20 10:17 EDT by Clayton Coleman
Modified: 2015-05-14 19:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:53:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-08-20 10:17:49 EDT
The cart reflector cartreflect-claytondev.rhcloud.com (gear 519817c8500446121700010b) is a Ruby cart and it appears at some point in production the ERB files weren't migrated correctly.

When I SSH in I get 

[Aug 13 10:10 cc4 ~/code/li]$ OPENSHIFT_CONFIG=prod rhc ssh cartreflect
Connecting to 519817c8500446121700010b@cartreflect-claytondev.rhcloud.com ...
bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier
bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier
bash: export: `OPENSHIFT_RUBY_LOG_DIR.erb=<%= ENV['OPENSHIFT_RUBY_DIR'] %>/logs/': not a valid identifier

...

And then when I find . -name *.erb I see

[cartreflect-claytondev.rhcloud.com 519817c8500446121700010b]\> find . -name *.erb
./ruby/env/OPENSHIFT_RUBY_LOG_DIR.erb
./ruby/versions/shared/etc/conf.d/openshift.conf.erb
./ruby/versions/1.9/etc/conf.d/openshift.conf.erb
./ruby/versions/1.8/etc/conf.d/openshift.conf.erb
./ruby/versions/2.0/etc/conf.d/openshift.conf.erb

It's possible other apps were affected - this app gets frequent traffic (10-40 requests a day) so it might be idled at various points.
Comment 1 Paul Morie 2013-08-20 15:59:08 EDT
It looks like there's a hole in the compatible upgrade workflow where an env ERB will not be removed unless it's reported in a cartridge's managed_files.yml 'processed_templates' section.
Comment 2 openshift-github-bot 2013-08-21 14:01:45 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/8f6838a3d639e7cff6db7553e7f8046dc2ba2fe0
Fix bug 999013: always remove unprocessed env/*.erb files from cartridge dir during compatible upgrade
Comment 3 Dan McPherson 2013-08-21 16:12:39 EDT
*** Bug 999667 has been marked as a duplicate of this bug. ***
Comment 4 Meng Bo 2013-08-22 05:19:55 EDT
Checked on devenv-stage_448,

Do upgrade and migration with the cartridge-reflector app.
After migration, there is no such error when ssh login.

And no .erb files left under cartridge/env dir.

[rubyapp-bmengdevstg1.dev.rhcloud.com 258754089030647598284800]\> find -name *erb
./ruby/versions/shared/etc/conf.d/openshift.conf.erb
./ruby/versions/1.8/etc/conf.d/openshift.conf.erb
./ruby/versions/2.0/etc/conf.d/openshift.conf.erb
./ruby/versions/1.9/etc/conf.d/openshift.conf.erb
./app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/sinatra-1.4.2/test/views/calc.html.erb
./app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/sinatra-1.4.2/test/views/utf8.erb
./app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/sinatra-1.4.2/test/views/layout2.erb
./app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/sinatra-1.4.2/test/views/error.erb
./app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/sinatra-1.4.2/test/views/hello.erb
./app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/sinatra-1.4.2/test/views/ascii.erb


Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.