Bug 991330 - External hard drive not mounting on kernel 3.10.X-XXX
External hard drive not mounting on kernel 3.10.X-XXX
Status: CLOSED DUPLICATE of bug 991668
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 03:29 EDT by Fabien Archambault
Modified: 2013-08-05 04:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 04:08:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabien Archambault 2013-08-02 03:29:29 EDT
Description of problem: After updating the kernel to version 3.10.3-300 and 3.10.4-300 my external USB hard drive cannot be mounted


Version-Release number of selected component (if applicable): kernel-3.10.4-300.fc19.x86_64


How reproducible: always


Steps to Reproduce:
1. Boot on kernel 3.10.4-300
2. Try to mount the external hard drive it does not mount
3. In kernel 3.9.9-302 it mounts flowlessly

Actual results:
WORKING case

$ dmesg
[  102.040276] usb 3-3: new high-speed USB device number 5 using xhci_hcd
[  102.057792] usb 3-3: New USB device found, idVendor=040d, idProduct=6208
[  102.057804] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  102.057810] usb 3-3: Product: USB 2.0 SATA Bridge
[  102.057814] usb 3-3: Manufacturer: VIA Technologies Inc.
[  102.057818] usb 3-3: SerialNumber: A787F52542A5
[  102.062019] scsi8 : usb-storage 3-3:1.0
[  103.064347] scsi 8:0:0:0: Direct-Access     SAMSUNG  HM400LI          2TF0 PQ: 0 ANSI: 2
[  103.064729] sd 8:0:0:0: Attached scsi generic sg2 type 0
[  103.064956] sd 8:0:0:0: [sdc] 781422765 512-byte logical blocks: (400 GB/372 GiB)
[  103.065284] sd 8:0:0:0: [sdc] Write Protect is off
[  103.065287] sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
[  103.065618] sd 8:0:0:0: [sdc] Asking for cache data failed
[  103.065621] sd 8:0:0:0: [sdc] Assuming drive cache: write through
[  103.067267] sd 8:0:0:0: [sdc] Asking for cache data failed
[  103.067270] sd 8:0:0:0: [sdc] Assuming drive cache: write through
[  103.128221]  sdc: sdc1
[  103.130085] sd 8:0:0:0: [sdc] Asking for cache data failed
[  103.130096] sd 8:0:0:0: [sdc] Assuming drive cache: write through
[  103.130103] sd 8:0:0:0: [sdc] Attached SCSI disk
[  103.708990] EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)
[  103.708996] SELinux: initialized (dev sdc1, type ext4), uses xattr

$ uname -a
Linux evangelion-nerv 3.9.9-302.fc19.x86_64 #1 SMP Sat Jul 6 13:41:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

NOT WORKING case

$ dmesg
[   61.299475] usb 3-3: new high-speed USB device number 5 using xhci_hcd
[   61.316592] usb 3-3: New USB device found, idVendor=040d, idProduct=6208
[   61.316598] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   61.316600] usb 3-3: Product: USB 2.0 SATA Bridge
[   61.316602] usb 3-3: Manufacturer: VIA Technologies Inc.
[   61.316604] usb 3-3: SerialNumber: A787F52542A5
[   61.317603] usb-storage 3-3:1.0: USB Mass Storage device detected
[   61.317652] scsi8 : usb-storage 3-3:1.0
[   62.320795] scsi 8:0:0:0: Direct-Access     SAMSUNG  HM400LI          2TF0 PQ: 0 ANSI: 2
[   62.321673] sd 8:0:0:0: Attached scsi generic sg2 type 0
[   62.322365] sd 8:0:0:0: [sdc] 781422765 512-byte logical blocks: (400 GB/372 GiB)
[   62.322698] sd 8:0:0:0: [sdc] Write Protect is off
[   62.322701] sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
[   62.323373] sd 8:0:0:0: [sdc] Asking for cache data failed
[   62.323377] sd 8:0:0:0: [sdc] Assuming drive cache: write through

$ uname -a
Linux evangelion-nerv 3.10.4-300.fc19.x86_64 #1 SMP Tue Jul 30 11:29:05 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 18d1:4e12 Google Inc. Nexus One (debug)
Bus 003 Device 003: ID 0461:4d81 Primax Electronics, Ltd Dell N889 Optical Mouse
Bus 003 Device 005: ID 040d:6208 VIA Technologies, Inc. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1bcf:2982 Sunplus Innovation Technology Inc. 
Bus 001 Device 004: ID 08ff:2810 AuthenTec, Inc. AES2810
Bus 002 Device 003: ID 0cf3:817a Atheros Communications, Inc. 
Bus 002 Device 004: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 002 Device 005: ID 0b97:7772 O2 Micro, Inc. OZ776 CCID Smartcard Reader

The computer where the tests are made is a Dell Latitude 6430u. I tried different USB port in order to check and also through a USB hub.

Feel free to ask some other tests.
Comment 1 Jean-maurice Le Clech 2013-08-03 12:06:10 EDT
Same problem with an iPod classic 160 Gio fat32
the iPod is seen by "lsusb" but never mounted
the ipod is well mounted with kernel 3.9.9.302 and also on windows (XP)
Comment 2 girl 2013-08-04 07:26:55 EDT
and with external sony usb3.0 hard drive
kernel 3.8 is normal
kernel 3.10, 3.11 does not mount
Comment 3 Fabien Archambault 2013-08-05 04:08:55 EDT

*** This bug has been marked as a duplicate of bug 991668 ***

Note You need to log in before you can comment on or make changes to this bug.