Bug 991668 - USB disk works in 3.9.9, but doesn't work in 3.10.4
USB disk works in 3.9.9, but doesn't work in 3.10.4
Status: CLOSED DUPLICATE of bug 989539
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 991330 996741 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 08:43 EDT by Hedayat Vatankhah
Modified: 2013-08-17 09:56 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 10:09:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2013-08-03 08:43:58 EDT
Description of problem:
I have two USB flash disks. One of them works in both 3.9.9 and 3.10.4. However, the other one works fine in 3.9.9, but doesn't work in 3.10.4. 
To be more accurate, in 3.10.4 the USB disk is recognized but its partition table cannot be read, while the same disk works fine in 3.9.9 (the partitions are recognized, and the disk is mounted successfully). In 3.10.4, even the device node in /dev/ is not created. 


Version-Release number of selected component (if applicable):
kernel-3.10.4-300.fc19.x86_64

How reproducible:
100%

This is the syslog output in 3.9.9:
========================================
Aug  3 16:09:01 localhost kernel: [  162.448102] usb 2-1: new high-speed USB device number 2 using ehci-pci
Aug  3 16:09:01 localhost kernel: [  162.564607] usb 2-1: New USB device found, idVendor=1516, idProduct=8628
Aug  3 16:09:01 localhost kernel: [  162.564620] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug  3 16:09:01 localhost kernel: [  162.564627] usb 2-1: Product: USB Drive
Aug  3 16:09:01 localhost kernel: [  162.564634] usb 2-1: Manufacturer: SKYMEDI
Aug  3 16:09:01 localhost kernel: [  162.564640] usb 2-1: SerialNumber: 03
Aug  3 16:09:01 localhost mtp-probe: checking bus 2, device 2: "/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-1"
Aug  3 16:09:01 localhost mtp-probe: bus: 2, device: 2 was not an MTP device
Aug  3 16:09:01 localhost kernel: [  162.639927] Initializing USB Mass Storage driver...
Aug  3 16:09:01 localhost kernel: [  162.640336] scsi3 : usb-storage 2-1:1.0
Aug  3 16:09:01 localhost kernel: [  162.641338] usbcore: registered new interface driver usb-storage
Aug  3 16:09:01 localhost kernel: [  162.641343] USB Mass Storage support registered.
Aug  3 16:09:02 localhost kernel: [  163.643050] scsi 3:0:0:0: Direct-Access     SKYMEDI  USB Drive             PQ: 0 ANSI: 2
Aug  3 16:09:02 localhost kernel: [  163.644587] sd 3:0:0:0: [sdb] 7847936 512-byte logical blocks: (4.01 GB/3.74 GiB)
Aug  3 16:09:02 localhost kernel: [  163.645101] sd 3:0:0:0: Attached scsi generic sg1 type 0
Aug  3 16:09:02 localhost kernel: [  163.645676] sd 3:0:0:0: [sdb] Write Protect is off
Aug  3 16:09:02 localhost kernel: [  163.646485] sd 3:0:0:0: [sdb] No Caching mode page present
Aug  3 16:09:02 localhost kernel: [  163.646496] sd 3:0:0:0: [sdb] Assuming drive cache: write through
Aug  3 16:09:02 localhost kernel: [  163.650491] sd 3:0:0:0: [sdb] No Caching mode page present
Aug  3 16:09:02 localhost kernel: [  163.650503] sd 3:0:0:0: [sdb] Assuming drive cache: write through
Aug  3 16:09:02 localhost kernel: [  163.768396]  sdb: sdb1
Aug  3 16:09:02 localhost kernel: [  163.770970] sd 3:0:0:0: [sdb] No Caching mode page present
Aug  3 16:09:02 localhost kernel: [  163.770976] sd 3:0:0:0: [sdb] Assuming drive cache: write through
Aug  3 16:09:02 localhost kernel: [  163.770980] sd 3:0:0:0: [sdb] Attached SCSI removable disk
Aug  3 16:09:02 localhost udisksd[1144]: Mounted /dev/sdb1 at /run/media/hedayat/KINGSTON on behalf of uid 1000
========================================

And this is the output in 3.10.4:
========================================
Aug  3 16:01:15 localhost kernel: [  257.285112] usb 2-1: new high-speed USB device number 23 using ehci-pci
Aug  3 16:01:15 localhost kernel: [  257.401616] usb 2-1: New USB device found, idVendor=1516, idProduct=8628
Aug  3 16:01:15 localhost kernel: [  257.401628] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug  3 16:01:15 localhost kernel: [  257.401636] usb 2-1: Product: USB Drive
Aug  3 16:01:15 localhost kernel: [  257.401643] usb 2-1: Manufacturer: SKYMEDI
Aug  3 16:01:15 localhost kernel: [  257.401649] usb 2-1: SerialNumber: 18
Aug  3 16:01:15 localhost kernel: [  257.403565] usb-storage 2-1:1.0: USB Mass Storage device detected
Aug  3 16:01:15 localhost kernel: [  257.405938] scsi6 : usb-storage 2-1:1.0
Aug  3 16:01:15 localhost mtp-probe: checking bus 2, device 23: "/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-1"
Aug  3 16:01:15 localhost mtp-probe: bus: 2, device: 23 was not an MTP device
Aug  3 16:01:16 localhost kernel: [  258.408055] scsi 6:0:0:0: Direct-Access     SKYMEDI  USB Drive             PQ: 0 ANSI: 2
Aug  3 16:01:16 localhost kernel: [  258.408956] sd 6:0:0:0: Attached scsi generic sg1 type 0
Aug  3 16:01:16 localhost kernel: [  258.409237] sd 6:0:0:0: [sdb] 7847936 512-byte logical blocks: (4.01 GB/3.74 GiB)
Aug  3 16:01:16 localhost kernel: [  258.410049] sd 6:0:0:0: [sdb] Write Protect is off
Aug  3 16:01:16 localhost kernel: [  258.410859] sd 6:0:0:0: [sdb] No Caching mode page present
Aug  3 16:01:16 localhost kernel: [  258.410870] sd 6:0:0:0: [sdb] Assuming drive cache: write through
Aug  3 16:01:46 localhost kernel: [  288.805092] usb 2-1: reset high-speed USB device number 23 using ehci-pci
Aug  3 16:02:17 localhost kernel: [  319.813091] usb 2-1: reset high-speed USB device number 23 using ehci-pci
Aug  3 16:02:48 localhost kernel: [  350.917106] usb 2-1: reset high-speed USB device number 23 using ehci-pci
Aug  3 16:03:19 localhost kernel: [  381.893095] usb 2-1: reset high-speed USB device number 23 using ehci-pci
Aug  3 16:03:20 localhost kernel: [  382.012511] sd 6:0:0:0: [sdb] No Caching mode page present
Aug  3 16:03:20 localhost kernel: [  382.012517] sd 6:0:0:0: [sdb] Assuming drive cache: write through
Aug  3 16:03:50 localhost kernel: [  412.869097] usb 2-1: reset high-speed USB device number 23 using ehci-pci
========================================

And when I disconnect the disk in 3.10.4:
==========================================
Aug  3 16:04:49 localhost kernel: [  471.134550] usb 2-1: USB disconnect, device number 23
Aug  3 16:04:49 localhost kernel: [  471.145208] ldm_validate_partition_table(): Disk read failed.
Aug  3 16:04:49 localhost kernel: [  471.145264] Dev sdb: unable to read RDB block 0
Aug  3 16:04:49 localhost kernel: [  471.145280]  sdb: unable to read partition table
Aug  3 16:04:49 localhost kernel: [  471.145442] sd 6:0:0:0: [sdb] Attached SCSI removable disk
==========================================
Comment 1 Georg Wittig 2013-08-03 10:16:23 EDT
Same problem here with a couple of USB sticks.
Wild guess: The problem only occurs on old USB-1.1 disks.(?)
Comment 2 Fabien Archambault 2013-08-05 04:08:55 EDT
*** Bug 991330 has been marked as a duplicate of this bug. ***
Comment 3 Fabien Archambault 2013-08-05 04:09:41 EDT
I closed mine https://bugzilla.redhat.com/show_bug.cgi?id=991330 as a duplicate of this one.
Comment 4 Fabien Archambault 2013-08-05 07:42:27 EDT
New interesting test. Using lshw. When trying to get the output with the hard drive plugged in the kernel 3.10.4-300 the output never finishes. I must unplug it to finish the SCSI check. There is clearly a very intrusive regression here!

# Generate lshw output on 2 different kernel:
$ su -c 'lshw' > lshw_$(uname -r).txt

$ ls lshw_3.*
lshw_3.10.4-300.fc19.x86_64.txt  lshw_3.9.9-302.fc19.x86_64.txt


Now get the diff, the only different part is the hard drive part:
$ diff -y lshw_3.*
[...]
							      >	     *-scsi:1
							      >	          physical id: 2
							      >	          bus info: usb@3:3
							      >	          logical name: scsi6
							      >	          capabilities: emulated scsi-host
							      >	          configuration: driver=usb-storage
							      >	        *-disk
							      >	             description: SCSI Disk
							      >	             physical id: 0.0.0
							      >	             bus info: scsi@6:0.0.0
							      >	             logical name: /dev/sdb
							      >	             size: 372GiB (400GB)
							      >	             capabilities: partitioned partitioned:dos
							      >	             configuration: sectorsize=512 signature=70000000
							      >	           *-volume
							      >	                description: EXT4 volume
							      >	                vendor: Linux
							      >	                physical id: 1
							      >	                bus info: scsi@6:0.0.0,1
							      >	                logical name: /dev/sdb1
							      >	                logical name: /run/media/archambaf/Evangelion
							      >	                version: 1.0
							      >	                serial: 7451fcfa-148b-44a9-8163-55966bba68c4
							      >	                size: 372GiB
							      >	                capacity: 372GiB
							      >	                capabilities: primary journaled extended_attr
							      >	                configuration: created=2013-06-14 09:21:42 fi
[...]
Comment 5 Kai Reichert 2013-08-07 16:35:24 EDT
I can confirm the same behaviour for the arm version of kernel 3.10.4

On my pandaboard (armv7) no usb is found with kernel 3.10.4.
UBoot and the previously installed kernel 3.9.9 are able to find all partitions.

The kernel log even shows some strange warnings only with kernel 3.10.4:
ehci-omap ehci-omap.0: Can't get PHY device for port 0: -517
Comment 6 Fabien Archambault 2013-08-08 02:53:30 EDT
I have just tested the new koji kernel : https://admin.fedoraproject.org/updates/kernel-3.10.5-201.fc19

Same issue. This needs to be very quickly fixed. Is it possible to increase the priority?
Comment 7 Fabien Archambault 2013-08-12 03:43:22 EDT
Here are some updates. I have taken this external hard drive to 2 other computers with F19 at latest version and kernel (kernel-3.10.5-201.fc19). One is a XPS M1330 laptop in 32 bits and another one a custom computer with a Fedora 64 bits system installed. On both computers I have the hard drive mounting on the 3.9.X kernel and not on the latest one.

This is clearly a problem due to the chip used within the external USB device. For information, the dmesg when plugged in:
[   85.256085] usb 2-1: new high-speed USB device number 5 using ehci-pci
[   85.375706] usb 2-1: New USB device found, idVendor=040d, idProduct=6208
[   85.375713] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   85.375718] usb 2-1: Product: USB 2.0 SATA Bridge
[   85.375723] usb 2-1: Manufacturer: VIA Technologies Inc.
[   85.375727] usb 2-1: SerialNumber: A787F52542A5
[   85.376756] usb-storage 2-1:1.0: USB Mass Storage device detected
[   85.377818] scsi6 : usb-storage 2-1:1.0
[   86.383840] scsi 6:0:0:0: Direct-Access     SAMSUNG  HM400LI          2TF0 PQ: 0 ANSI: 2
[   86.386638] sd 6:0:0:0: Attached scsi generic sg2 type 0
[   86.387578] sd 6:0:0:0: [sdb] 781422765 512-byte logical blocks: (400 GB/372 GiB)
[   86.388066] sd 6:0:0:0: [sdb] Write Protect is off
[   86.388070] sd 6:0:0:0: [sdb] Mode Sense: 00 00 00 00
[   86.388580] sd 6:0:0:0: [sdb] Asking for cache data failed
[   86.388584] sd 6:0:0:0: [sdb] Assuming drive cache: write through
Comment 8 Simon Gerhards 2013-08-12 09:03:39 EDT
This bug has an upstream patch and is hopefully fixed soon:
https://bugzilla.kernel.org/show_bug.cgi?id=60685

It was discussed on the USB for Linux mailing list:
http://www.spinics.net/lists/linux-usb/msg90486.html

The proposed patch appears in this post:
http://www.spinics.net/lists/linux-usb/msg90555.html
Comment 9 Alexander Ploumistos 2013-08-14 04:35:45 EDT
Any news on when a patched kernel will appear in koji?
Will it be a 3.10 or a 3.11 series kernel for Fedora 19?
Comment 10 Josh Boyer 2013-08-15 10:07:38 EDT
The commit that fixed this is in 3.10.7.  There should be a build of that later today.
Comment 11 Josh Boyer 2013-08-15 10:07:49 EDT
*** Bug 996741 has been marked as a duplicate of this bug. ***
Comment 12 Josh Boyer 2013-08-15 10:09:37 EDT

*** This bug has been marked as a duplicate of bug 989539 ***
Comment 13 Alexander Ploumistos 2013-08-16 05:08:37 EDT
Tested 3.10.7 with every USB flash drive I own and they all work fine.
Nice job!
Comment 14 klaus 2013-08-17 09:56:17 EDT
Excellent! Installed kernel 3.10.7, USB-drives are back! Thanks for your job!

Note You need to log in before you can comment on or make changes to this bug.