Bug 99139 - Problems with fonst, especially around letter u
Summary: Problems with fonst, especially around letter u
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: urw-fonts   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-14 22:45 UTC by Trever Adams
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-15 11:43:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Slashdot shot showing problem (61.12 KB, image/jpeg)
2003-07-14 22:47 UTC, Trever Adams
no flags Details

Description Trever Adams 2003-07-14 22:45:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Since I upgraded from RH9 to Rawhide, font rendering is screwy.  I believe this
is a urw problem, but it may be a rendering problem (freetype, XFree86, etc). 
Anyway, I have attached a partial show of slashdot showing the problem.  You
will notice there is no baseline, especially when it comes to the letter u.

Below are is rpm -qa | grep font for reference, in the case it is something else.

XFree86-base-fonts-4.3.0-17
XFree86-100dpi-fonts-4.3.0-17
fontilus-0.3-4
ttfonts-ja-1.2-21
XFree86-font-utils-4.3.0-17
tetex-fonts-1.0.7-66
fontconfig-devel-2.1-9
fontconfig-2.1-9
bitstream-vera-fonts-1.10-2
chkfontpath-1.9.10-2
bitmap-fonts-0.3-2
ghostscript-fonts-5.50-9
XFree86-truetype-fonts-4.3.0-17
urw-fonts-2.1-2
XFree86-75dpi-fonts-4.3.0-17


(unless the rpm for bitstream vera changed my settings, it should be irrelevant
to the problem)

Version-Release number of selected component (if applicable):
urw-fonts-2.1-2

How reproducible:
Always

Steps to Reproduce:
See the above.
    

Additional info:

Comment 1 Trever Adams 2003-07-14 22:47:48 UTC
Created attachment 92923 [details]
Slashdot shot showing problem

This shows the problem.  Look at lower cases u among others.  It should show a
baseline problem (baseline being where the bottom of anything but decending
lines should rest).

Comment 2 Ngo Than 2003-08-15 11:43:47 UTC
urw-fonts looks ok for me, it seems it's a bug in freetype. i cannot reproduce
it on my local machine with:
  XFree86-4.3.0-18
  fontconfig-2.2.1-4
  freetype-2.1.4-4.0
  urw-fonts-2.1-1

could you please upgrade the new rpms from rawhide, and try again.
please reopen it if this problem still appears. thanks

Comment 3 Trever Adams 2004-01-21 17:55:58 UTC
Fonts that seem to be affected:

Nimbus, Serif (not sure where this font resides).


Note You need to log in before you can comment on or make changes to this bug.