Bug 991548 - "auto-attach" in gui for already entitled system shows "Error" dialog
"auto-attach" in gui for already entitled system shows "Error" dialog
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 5.10
Assigned To: John Sefler
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-08-02 13:32 EDT by Adrian Likins
Modified: 2013-09-30 19:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:15:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error dialog (7.01 KB, image/png)
2013-08-02 13:32 EDT, Adrian Likins
no flags Details
Expected Dialog (44.01 KB, image/png)
2013-08-02 14:02 EDT, Matt Reid
no flags Details
Repeated click of "Auto-attach" button yields expected dialog. (101.82 KB, image/png)
2013-08-15 12:32 EDT, John Sefler
no flags Details

  None (edit)
Description Adrian Likins 2013-08-02 13:32:20 EDT
Created attachment 782084 [details]
screenshot of error dialog

Description of problem:

On a system that is green, the "auto attach" button on the "My Installed
Products" tab is still clickable. 

Clicking on it results in an error dialog being shown with the text
"Error subscribing". (see attachment for screenshot).

rhsm.log2013-08-02 13:27:32,841 [DEBUG]  @injection.py:72 - Initializing singleton for feature IDENTITY
2013-08-02 13:27:32,841 [DEBUG]  @identity.py:130 - Loading consumer info from identity certificates.
2013-08-02 13:27:32,851 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:32,852 [DEBUG]  @injection.py:72 - Initializing singleton for feature CP_PROVIDER
2013-08-02 13:27:32,853 [DEBUG]  @injection.py:80 - Returning instance for feature CP_PROVIDER
2013-08-02 13:27:32,854 [DEBUG]  @profile.py:96 - Loading current RPM profile.
2013-08-02 13:27:33,318 [INFO]  @connection.py:586 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = True
2013-08-02 13:27:33,318 [INFO]  @connection.py:597 - Connection Built: host: snarl.usersys.redhat.com, port: 8443, handler: /candlepin
2013-08-02 13:27:33,319 [DEBUG]  @connection.py:199 - ContectConnection
2013-08-02 13:27:33,319 [DEBUG]  @injection.py:72 - Initializing singleton for feature PROD_DIR
2013-08-02 13:27:33,320 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_DIR
2013-08-02 13:27:33,320 [DEBUG]  @injection.py:72 - Initializing singleton for feature ENT_DIR
2013-08-02 13:27:33,320 [DEBUG]  @injection.py:80 - Returning instance for feature ENT_DIR
2013-08-02 13:27:33,320 [DEBUG]  @injection.py:72 - Initializing singleton for feature CERT_SORTER
2013-08-02 13:27:33,320 [DEBUG]  @injection.py:80 - Returning instance for feature CP_PROVIDER
2013-08-02 13:27:33,321 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_DIR
2013-08-02 13:27:33,321 [DEBUG]  @injection.py:80 - Returning instance for feature ENT_DIR
2013-08-02 13:27:33,321 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:33,321 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_DIR
2013-08-02 13:27:33,323 [INFO]  @cache.py:168 - Checking current system info against cache: /var/lib/rhsm/cache/installed_products.json
2013-08-02 13:27:33,324 [INFO]  @cache.py:185 - No changes.
2013-08-02 13:27:33,324 [DEBUG]  @certdirectory.py:204 - Installed product IDs: ['37060']
2013-08-02 13:27:33,324 [DEBUG]  @injection.py:72 - Initializing singleton for feature STATUS_CACHE
2013-08-02 13:27:33,324 [DEBUG]  @injection.py:80 - Returning instance for feature STATUS_CACHE
2013-08-02 13:27:33,325 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/6233031c-550b-4a18-a64a-aa4fc5f3765b/compliance
2013-08-02 13:27:33,503 [DEBUG]  @connection.py:434 - Response status: 200
2013-08-02 13:27:33,505 [DEBUG]  @cache.py:284 - Started thread to write cache: /var/lib/rhsm/cache/entitlement_status.json
2013-08-02 13:27:33,509 [DEBUG]  @cert_sorter.py:266 - valid entitled products: ['37060']
2013-08-02 13:27:33,509 [DEBUG]  @cert_sorter.py:267 - expired entitled products: []
2013-08-02 13:27:33,510 [DEBUG]  @cert_sorter.py:268 - partially entitled products: []
2013-08-02 13:27:33,510 [DEBUG]  @cert_sorter.py:269 - unentitled products: []
2013-08-02 13:27:33,510 [DEBUG]  @cert_sorter.py:270 - future products: []
2013-08-02 13:27:33,510 [DEBUG]  @cert_sorter.py:271 - partial stacks: []
2013-08-02 13:27:33,511 [DEBUG]  @cert_sorter.py:272 - entitlements valid until: 2014-08-01 00:00:01+00:00
2013-08-02 13:27:33,511 [DEBUG]  @injection.py:80 - Returning instance for feature CERT_SORTER
2013-08-02 13:27:33,511 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:33,512 [DEBUG]  @injection.py:72 - Initializing singleton for feature PLUGIN_MANAGER
2013-08-02 13:27:33,513 [DEBUG]  @plugins.py:519 - loaded plugin modules: []
2013-08-02 13:27:33,513 [DEBUG]  @plugins.py:520 - loaded plugins: {}
2013-08-02 13:27:33,513 [DEBUG]  @injection.py:80 - Returning instance for feature PLUGIN_MANAGER
2013-08-02 13:27:33,525 [DEBUG]  @hwprobe.py:519 - cpu info: {'cpu.cpu(s)': 8, 'cpu.core(s)_per_socket': 4, 'cpu.thread(s)_per_core': 1, 'cpu.topology_source': 'kernel /sys cpu sibling lists', 'cpu.cpu_socket(s)': 2}
2013-08-02 13:27:33,687 [INFO]  @facts.py:137 - Loading custom facts from: /etc/rhsm/facts/foo.facts
2013-08-02 13:27:33,688 [DEBUG]  @managergui.py:147 - Client Versions: {'python-rhsm': '1.9.1-1.git.1.9440db9.el6', 'subscription-manager': '1.9.0-1.git.44.298fa1d.el6'} 
2013-08-02 13:27:33,760 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/
2013-08-02 13:27:33,779 [DEBUG]  @connection.py:434 - Response status: 200
2013-08-02 13:27:33,780 [DEBUG]  @connection.py:613 - Server supports the following resources:
2013-08-02 13:27:33,781 [DEBUG]  @connection.py:614 - {'': '/', 'hypervisors': '/hypervisors', 'serials': '/serials', 'deleted_consumers': '/deleted_consumers', 'consumers': '/consumers', 'migrations': '/migrations', 'content': '/content', 'entitlements': '/entitlements', 'statistics/generate': '/statistics/generate', 'status': '/status', 'jobs': '/jobs', 'users': '/users', 'subscriptions': '/subscriptions', 'rules': '/rules', 'distributor_versions': '/distributor_versions', 'consumertypes': '/consumertypes', 'activation_keys': '/activation_keys', 'atom': '/atom', 'owners': '/owners', 'roles': '/roles', 'admin': '/admin', 'events': '/events', 'products': '/products', 'pools': '/pools', 'crl': '/crl'}
2013-08-02 13:27:33,781 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/status
2013-08-02 13:27:33,809 [DEBUG]  @connection.py:434 - Response status: 200
2013-08-02 13:27:33,810 [DEBUG]  @managergui.py:148 - Server Versions: {'candlepin': '0.8.19-1', 'server-type': 'Red Hat Subscription Management'} 
2013-08-02 13:27:33,829 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:33,844 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:33,844 [DEBUG]  @injection.py:80 - Returning instance for feature PLUGIN_MANAGER
2013-08-02 13:27:33,883 [DEBUG]  @injection.py:80 - Returning instance for feature CP_PROVIDER
2013-08-02 13:27:33,939 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,000 [DEBUG]  @injection.py:80 - Returning instance for feature CP_PROVIDER
2013-08-02 13:27:34,010 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,032 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,045 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,117 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,118 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,118 [DEBUG]  @injection.py:80 - Returning instance for feature PLUGIN_MANAGER
2013-08-02 13:27:34,231 [DEBUG]  @injection.py:77 - Returning callable provider for feature PRODUCT_DATE_RANGE_CALCULATOR: <function factory at 0x1254cf8>
2013-08-02 13:27:34,231 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:34,232 [DEBUG]  @injection.py:72 - Initializing singleton for feature PROD_STATUS_CACHE
2013-08-02 13:27:34,232 [DEBUG]  @injection.py:80 - Returning instance for feature PROD_STATUS_CACHE
2013-08-02 13:27:34,233 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/6233031c-550b-4a18-a64a-aa4fc5f3765b
2013-08-02 13:27:34,350 [DEBUG]  @connection.py:434 - Response status: 200
2013-08-02 13:27:34,352 [DEBUG]  @cache.py:284 - Started thread to write cache: /var/lib/rhsm/cache/product_status.json
2013-08-02 13:27:34,381 [DEBUG]  @injection.py:72 - Initializing singleton for feature DBUS_IFACE
2013-08-02 13:27:34,393 [DEBUG]  @injection.py:80 - Returning instance for feature DBUS_IFACE
2013-08-02 13:27:34,394 [DEBUG]  @injection.py:80 - Returning instance for feature CERT_SORTER
2013-08-02 13:27:34,443 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/6233031c-550b-4a18-a64a-aa4fc5f3765b
2013-08-02 13:27:34,580 [DEBUG]  @connection.py:434 - Response status: 200
2013-08-02 13:27:34,642 [DEBUG]  @injection.py:54 - Registering provider for feature IDENTITY: <class 'subscription_manager.identity.Identity'>
2013-08-02 13:27:34,642 [DEBUG]  @injection.py:54 - Registering provider for feature PRODUCT_DATE_RANGE_CALCULATOR: <function factory at 0x7f6f13b106e0>
2013-08-02 13:27:34,643 [DEBUG]  @injection.py:54 - Registering provider for feature ENT_DIR: <class 'subscription_manager.certdirectory.EntitlementDirectory'>
2013-08-02 13:27:34,643 [DEBUG]  @injection.py:54 - Registering provider for feature PROD_DIR: <class 'subscription_manager.certdirectory.ProductDirectory'>
2013-08-02 13:27:34,643 [DEBUG]  @injection.py:54 - Registering provider for feature STATUS_CACHE: <class 'subscription_manager.cache.StatusCache'>
2013-08-02 13:27:34,643 [DEBUG]  @injection.py:54 - Registering provider for feature PROD_STATUS_CACHE: <class 'subscription_manager.cache.ProductStatusCache'>
2013-08-02 13:27:34,643 [DEBUG]  @injection.py:54 - Registering provider for feature CP_PROVIDER: <class 'subscription_manager.cp_provider.CPProvider'>
2013-08-02 13:27:34,644 [DEBUG]  @injection.py:54 - Registering provider for feature CERT_SORTER: <class 'subscription_manager.cert_sorter.CertSorter'>
2013-08-02 13:27:34,644 [DEBUG]  @injection.py:54 - Registering provider for feature PLUGIN_MANAGER: <class 'subscription_manager.plugins.PluginManager'>
2013-08-02 13:27:34,644 [DEBUG]  @injection.py:54 - Registering provider for feature DBUS_IFACE: <class 'subscription_manager.dbus_interface.DbusIface'>
2013-08-02 13:27:34,646 [INFO]  @rhsmd:190 - rhsmd started
2013-08-02 13:27:34,670 [INFO]  @rhsmd:147 - D-Bus interface com.redhat.SubscriptionManager.EntitlementStatus.update_status called with status = 0
2013-08-02 13:27:34,745 [INFO]  @rhsmd:115 - D-Bus signal com.redhat.SubscriptionManager.EntitlementStatus.entitlement_status_changed emitted
2013-08-02 13:27:36,160 [DEBUG]  @injection.py:80 - Returning instance for feature IDENTITY
2013-08-02 13:27:36,160 [DEBUG]  @injection.py:80 - Returning instance for feature PLUGIN_MANAGER
2013-08-02 13:27:36,199 [DEBUG]  @injection.py:80 - Returning instance for feature CP_PROVIDER
2013-08-02 13:27:36,331 [DEBUG]  @connection.py:415 - Making request: GET /candlepin/consumers/6233031c-550b-4a18-a64a-aa4fc5f3765b
2013-08-02 13:27:36,460 [DEBUG]  @connection.py:434 - Response status: 200
2013-08-02 13:27:36,462 [ERROR]  @utils.py:70 - None
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 1105, in _find_service_levels
    suitable_slas = self._find_suitable_service_levels(consumer, facts)
  File "/usr/share/rhsm/subscription_manager/gui/registergui.py", line 1074, in _find_suitable_service_levels
    raise AllProductsCoveredException()
AllProductsCoveredException





Version-Release number of selected component (if applicable):
commit 6abb15792c9f021cfa8b7aea18da7a2a4160d38d in the RHEL5.10 subscription-manager branch

(though, this is actually tested on a RHEL6 box)

How reproducible:
always
Comment 1 Matt Reid 2013-08-02 14:02:50 EDT
Created attachment 782116 [details]
Expected Dialog

This is the normal message when trying to run auto-attach when you're green.
Comment 3 Alex Wood 2013-08-05 09:29:58 EDT
commit 9a6b5eb5700854ab521ee22c0c5438e120cd7f13
Author: Alex Wood <awood@redhat.com>
Date:   Fri Aug 2 14:16:53 2013 -0400

    991548: Display correct error message for registration failures.
Comment 5 John Sefler 2013-08-15 12:32:05 EDT
Created attachment 786982 [details]
Repeated click of "Auto-attach" button yields expected dialog.

Verifying Version...
[root@jsefler-5 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.8.20-1.el5

For both of these cases:
1. No installed products
2. Already compliant

Repeated clicking of the Auto-attach button is successfully displaying the expected dialog.

Moving to VERIFIED
Comment 7 errata-xmlrpc 2013-09-30 19:15:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.