Bug 991591 - IP address for br-ex does not persist across reboots in allinone install
IP address for br-ex does not persist across reboots in allinone install
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 4.0
Assigned To: Martin Magr
Nir Magnezi
:
Depends On:
Blocks: 1022574
  Show dependency treegraph
 
Reported: 2013-08-02 16:02 EDT by Terry Wilson
Modified: 2016-04-26 18:17 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.4.dev740.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: IP details of br-ex bridge not assigned properly during packstack install. Consequence: IP details were lost upon reboot. Fix: packstack was modified to ensure IP details are persistent. Result: IP details are not lost upon reboot.
Story Points: ---
Clone Of:
: 1022574 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:16:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 43787 None None None Never

  None (edit)
Description Terry Wilson 2013-08-02 16:02:47 EDT
Description of problem:

When rebooting after a packstack allinone install, the IP setup on the br-ex bridge is lost.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. packstack --allinone
2. reboot
3. ifconfig br-ex

Actual results:

No IP

Expected results:

Has IP
Comment 2 Terry Wilson 2013-08-05 14:32:56 EDT
This should have been filed against openstack-packstack and there is no external tracker for packstack.
Comment 3 Alan Pevec 2013-09-30 19:10:47 EDT
> there is no external tracker for packstack.

there is bugs.launchpad.net/packstack
Comment 5 Nir Magnezi 2013-11-12 02:16:26 EST
Verified NVR: openstack-packstack-2013.2.1-0.9.dev840.el6ost.noarch

Followed Comment #0

Result: br-ex IP address is now persistent.
Comment 8 errata-xmlrpc 2013-12-19 19:16:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.