Bug 991679 - (cron-to-timer-units) TRACKER: Systemd timer unit migration
TRACKER: Systemd timer unit migration
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vokal
Radek Vokal
: FutureFeature, Tracking
Depends On: 1053590 991684 991696 1064537 1077640
Blocks: 1076445
  Show dependency treegraph
 
Reported: 2013-08-03 10:58 EDT by Jóhann B. Guðmundsson
Modified: 2014-04-23 08:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 08:59:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2013-08-03 10:58:09 EDT
Description of problem:

Cron jobs to systemd timer units migration

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jaroslav Reznik 2013-09-16 04:48:57 EDT
Adding Tracking, FutureFeature keywords to avoid rawhide -> f20 rebase of this bug.
Comment 4 Jóhann B. Guðmundsson 2014-03-17 09:03:59 EDT
Just a side note that the necessary rework and cleanup of all the systemd units in Fedora will be kept in a separated Feature/tracking bug
Comment 5 Jóhann B. Guðmundsson 2014-03-19 10:35:18 EDT
Tomasz sysstat wont be migrated
Comment 6 Jóhann B. Guðmundsson 2014-04-23 08:59:39 EDT
I have formally retracted this feature since FPC members are under the assumption that it is fine to introduce a new package or a sub package and have that sub package depend on systemd when neither that nor the original package contained systemd units or otherwise has or had an existing hard dependency on systemd.

In other words they have chosen to introduce an dependency on systemd where there should be none which at that point you could just as well migrate everything from cron to systemd unit which requires a completely different implementation ( thus completely differently constructed section in the guidelines ) and is absolutely not the intention of my proposal since cron is not 1 to 1 replacement for systemd.

Cronie has it's purpose for those components that do not depend on systemd as well as serving administrative and end users cron jobs handler and we should keep it that way since both components ( systemd-timers and cronie ) complement each other. 

But since FPC are such experts on how this should be implemented in the distribution it's best to allow them to do just that as well as observer how and what they themselves will actually migrated and leave Red Hat to clean up that mess they will leave behind in RHEL 8 and it will start affecting RHEL customers. 

Good luck!

Note You need to log in before you can comment on or make changes to this bug.