Bug 1076445 - cron to systemd time units
cron to systemd time units
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
ChangeAcceptedF21
:
Depends On: requires-crontabs cron-to-timer-units
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-14 07:09 EDT by Jaroslav Reznik
Modified: 2014-10-14 08:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-23 08:58:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note-


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2014-03-14 07:09:38 EDT
This is a tracking bug for Change: cron to systemd time units
For more details, see: http://fedoraproject.org//wiki/Changes/cron-to-systemd-time-units

Fix dependency on crontab in packages containing cron jobs as well as migrate cron jobs that are applicable to native systemd timer units.
Comment 1 Jóhann B. Guðmundsson 2014-04-23 08:58:47 EDT
I have formally retracted this feature since FPC members are under the assumption that it is fine to introduce a new package or a sub package and have that sub package depend on systemd when neither that nor the original package contained systemd units or otherwise has or had an existing hard dependency on systemd.

In other words they have chosen to introduce an dependency on systemd where there should be none which at that point you could just as well migrate everything from cron to systemd unit which requires a completely different implementation ( thus completely differently constructed section in the guidelines ) and is absolutely not the intention of my proposal since cron is not 1 to 1 replacement for systemd.

Cronie has it's purpose for those components that do not depend on systemd as well as serving administrative and end users cron jobs handler and we should keep it that way since both components ( systemd-timers and cronie ) complement each other. 

But since FPC are such experts on how this should be implemented in the distribution it's best to allow them to do just that as well as observer how and what they themselves will actually migrated and leave Red Hat to clean up that mess they will leave behind in RHEL 8 and it will start affecting RHEL customers. 

Good luck!

Note You need to log in before you can comment on or make changes to this bug.