Bug 991706 - Update requires java-devel
Update requires java-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhino (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
: 993628 (view as bug list)
Depends On:
Blocks: 1000893
  Show dependency treegraph
 
Reported: 2013-08-03 17:04 EDT by Michael Cronenworth
Modified: 2013-09-06 01:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: rhino-1.7R4-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 04:18:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2013-08-03 17:04:58 EDT
Description of problem:

rhino is required by java-1.7.0-openjdk. With the latest update, rhino needs java-1.7.0-openjdk-devel. Now you have a -devel package installed on *every desktop install*.

The changelog says it's due to a runtime requires, but I can run the old "rhino" at a command line without an error.

Please remove this new requires on java-1.7.0-openjdk-devel.


Version-Release number of selected component (if applicable):
rhino-1.7R4-4.fc19


Additional info:

Your changelog entry was also with an invalid email address. (<akurtakov@localhost.localdomain>)

Please be more careful when you push changes to Fedora.
Comment 1 Dominik 'Rathann' Mierzejewski 2013-08-06 16:14:21 EDT
*** Bug 993628 has been marked as a duplicate of this bug. ***
Comment 2 Michael Cronenworth 2013-08-12 20:07:59 EDT
Ping: anyone.

Is there an update on this?
Comment 3 Alexander Kurtakov 2013-08-13 03:49:16 EDT
Michael, 
Hi (I was on vacation), I'm going to look at it, it definetely doesn't work for me without devel installed probably some of the jpackage helper functions doesn't find the plain jvm after the directory structure was changed a bit. I'll try to fix it there and drop the devel requirement after that.
According to the 3 +1s I got in bodhi the workaround helped people that were complaining on irc. Even if not the perfect fix that the easiest way to help them while finding the bigger issue.
Btw, just to double check are you stating that starting /usr/bin/rhino works without java-devel installed or that java -jar /usr/share/java/rhino.jar works?
Comment 4 Kalev Lember 2013-08-26 15:34:58 EDT
This is dragging java-devel to the Desktop live media and contributing to making it over size for F20.
Comment 6 Fedora Update System 2013-09-01 06:41:52 EDT
rhino-1.7R4-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rhino-1.7R4-5.fc19
Comment 7 Fedora Update System 2013-09-06 00:01:29 EDT
rhino-1.7R4-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-09-06 01:14:51 EDT
rhino-1.7R4-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.