Bug 993628 - rhino depends on java-devel
rhino depends on java-devel
Status: CLOSED DUPLICATE of bug 991706
Product: Fedora
Classification: Fedora
Component: rhino (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 06:04 EDT by Alexey I. Froloff
Modified: 2013-08-06 16:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 16:14:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey I. Froloff 2013-08-06 06:04:27 EDT
rhino should not depend on java-devel, bacause java-openjdk -> rhino -> java-openjdk-devel dependency chain ruins the whole idea of java-openjdk-devel subpackage.

# yum remove java-1.7.0-openjdk-devel
...
Resolving Dependencies
--> Running transaction check
---> Package java-1.7.0-openjdk-devel.x86_64 1:1.7.0.25-2.3.12.3.fc19 will be erased
--> Processing Dependency: java-devel >= 1:1.6.0.0 for package: rhino-1.7R4-4.fc19.noarch
--> Running transaction check
---> Package rhino.noarch 0:1.7R4-4.fc19 will be erased
--> Processing Dependency: rhino for package: 1:java-1.7.0-openjdk-1.7.0.25-2.3.12.3.fc19.x86_64
--> Running transaction check
---> Package java-1.7.0-openjdk.x86_64 1:1.7.0.25-2.3.12.3.fc19 will be erased
...
Found and removing 0 unneeded dependencies

Dependencies Resolved

Removing:
 java-1.7.0-openjdk-devel
Removing for dependencies:
 bouncycastle
 bouncycastle-mail
 bouncycastle-tsp
 eclipse-swt
 icedtea-web
 itext-core
 java-1.7.0-openjdk
 libreoffice-calc
 libreoffice-core
 libreoffice-draw
 libreoffice-graphicfilter
 libreoffice-impress
 libreoffice-math
 libreoffice-pdfimport
 libreoffice-ure
 libreoffice-writer
 libreoffice-xsltfilter
 rhino
 tuxguitar

Transaction Summary
Remove  1 Package (+19 Dependent packages)
Comment 1 Dominik 'Rathann' Mierzejewski 2013-08-06 16:14:21 EDT

*** This bug has been marked as a duplicate of bug 991706 ***

Note You need to log in before you can comment on or make changes to this bug.