Bug 991726 - xHCI xhci_drop_endpoint called with disabled ep
xHCI xhci_drop_endpoint called with disabled ep
Status: CLOSED DUPLICATE of bug 989539
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 01:16 EDT by Nirmal Pathak
Modified: 2013-08-18 07:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 07:58:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
System Logs (2.48 KB, text/plain)
2013-08-04 01:16 EDT, Nirmal Pathak
no flags Details

  None (edit)
Description Nirmal Pathak 2013-08-04 01:16:16 EDT
Created attachment 782413 [details]
System Logs

Description of problem:
The OS does not detect my Digital Camera on Fedora 19.

Version-Release number of selected component (if applicable):
Fedora 19
Linux - 3.10.4-300.fc19.x86_64

How reproducible:
Attach a Digital Camera/USB Storage Device to mount.

Steps to Reproduce:
1. Attach USB Storage Device
2. 
3.

Actual results:
Does not auto mount the device.

Expected results:
The device should auto mount to access the contents.

Additional info:

[ 3546.998251]  sdb: sdb1
[ 3546.998258] sdb: p1 size 7753728 extends beyond EOD, enabling native capacity
[ 3546.998866] sd 7:0:0:0: [sdb] Adjusting the sector count from its reported value: 7761920
[ 3546.999397] sd 7:0:0:0: [sdb] No Caching mode page present
[ 3546.999403] sd 7:0:0:0: [sdb] Assuming drive cache: write through
[ 3577.970928] usb 3-1: reset high-speed USB device number 4 using xhci_hcd
[ 3577.982650] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff880207e21280
[ 3577.982657] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff880207e212c0
Comment 1 Nirmal Pathak 2013-08-09 17:35:26 EDT
This issue looks similar to what has been discussed here http://marc.info/?l=linux-usb&m=137493436022486&w=2
Comment 2 Nirmal Pathak 2013-08-10 23:03:09 EDT
Latest Fedora 19 kernel also doesn't fix the issue.

Linux - 3.10.5-201.fc19.x86_64
==
Aug 10 19:55:47 ideapad kernel: [92648.276844] usb 3-1: new high-speed USB device number 3 using xhci_hcd
Aug 10 19:55:47 ideapad kernel: [92648.289557] usb 3-1: New USB device found, idVendor=04da, idProduct=2372
Aug 10 19:55:47 ideapad kernel: [92648.289562] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Aug 10 19:55:47 ideapad kernel: [92648.289563] usb 3-1: Product: DMC-TZ20
Aug 10 19:55:47 ideapad kernel: [92648.289565] usb 3-1: Manufacturer: Panasonic
Aug 10 19:55:47 ideapad kernel: [92648.289566] usb 3-1: SerialNumber: 0000000000000000005F1711120362
Aug 10 19:55:47 ideapad mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1"
Aug 10 19:55:47 ideapad mtp-probe: bus: 3, device: 3 was not an MTP device
Aug 10 19:55:47 ideapad kernel: [92648.467052] usb-storage 3-1:1.0: USB Mass Storage device detected
Aug 10 19:55:47 ideapad kernel: [92648.467093] usb-storage 3-1:1.0: Quirks match for vid 04da pid 2372: 90
Aug 10 19:55:47 ideapad kernel: [92648.467120] scsi6 : usb-storage 3-1:1.0
Aug 10 19:55:47 ideapad kernel: [92648.467207] usbcore: registered new interface driver usb-storage
Aug 10 19:55:48 ideapad kernel: [92649.468862] scsi 6:0:0:0: Direct-Access     MATSHITA DMC-TZ20         0120 PQ: 0 ANSI: 2
Aug 10 19:55:48 ideapad kernel: [92649.469531] sd 6:0:0:0: Attached scsi generic sg2 type 0
Aug 10 19:55:48 ideapad kernel: [92649.470354] sd 6:0:0:0: [sdb] Adjusting the sector count from its reported value: 7761920
Aug 10 19:55:48 ideapad kernel: [92649.470362] sd 6:0:0:0: [sdb] 7761919 512-byte logical blocks: (3.97 GB/3.70 GiB)
Aug 10 19:55:48 ideapad kernel: [92649.472089] sd 6:0:0:0: [sdb] Write Protect is off
Aug 10 19:55:48 ideapad kernel: [92649.472338] sd 6:0:0:0: [sdb] No Caching mode page present
Aug 10 19:55:48 ideapad kernel: [92649.472341] sd 6:0:0:0: [sdb] Assuming drive cache: write through
Aug 10 19:55:52 ideapad fprintd[29177]: ** Message: No devices in use, exit
Aug 10 19:56:18 ideapad kernel: [92679.753743] usb 3-1: reset high-speed USB device number 3 using xhci_hcd
Aug 10 19:56:18 ideapad kernel: [92679.765388] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e5a14000
Aug 10 19:56:18 ideapad kernel: [92679.765403] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801e5a14040
==
Comment 3 Josh Boyer 2013-08-16 13:24:36 EDT
If this is the issue pointed to by the mailing list thread, it should be fixed with the 3.10.7 update in updates-testing.  Could you please try that and let us know if it's resolved?

https://admin.fedoraproject.org/updates/kernel-3.10.7-200.fc19
Comment 4 Nirmal Pathak 2013-08-17 11:02:08 EDT
This is fixed with 3.10.7-200.fc19.x86_64.
Comment 5 Josh Boyer 2013-08-18 07:58:50 EDT
Thanks.

*** This bug has been marked as a duplicate of bug 989539 ***

Note You need to log in before you can comment on or make changes to this bug.