Bug 989539 - USB stick not able to mount with kernel 3.10
Summary: USB stick not able to mount with kernel 3.10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 991668 991676 991726 998100 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-29 13:33 UTC by lev
Modified: 2013-11-01 19:36 UTC (History)
15 users (show)

Fixed In Version: kernel-3.10.7-200.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-18 00:33:03 UTC


Attachments (Terms of Use)
On kernel 3.9 and 3.10 (638 bytes, text/plain)
2013-07-29 13:33 UTC, lev
no flags Details
Patch from the upstream bug report (819 bytes, patch)
2013-08-11 21:39 UTC, Lukas Middendorf
no flags Details | Diff

Description lev 2013-07-29 13:33:57 UTC
Created attachment 779895 [details]
On kernel 3.9 and 3.10

Description of problem:
After today`s upgrade to kernel 3.10 one of my USB sticks won`t be able to automount. With kernel 3.9 work`s well.
fdisk don`t see new disk, no new device.
Other USB disks are working fine.

there are some info in attached files.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Not mounted.

Expected results:
Mounted

Additional info:

Comment 1 Lukas Middendorf 2013-08-04 21:27:25 UTC
Have the same problem. One USB key works, an other does not work.
After waiting some minutes it is possible to mount the partition on the key manually, but udisks does not seem to recognize it.

This seems to be the upstream bug:
https://bugzilla.kernel.org/show_bug.cgi?id=60664

This is the dmesg output for the not working device:

[32158.411588] usb 2-1.8: new high-speed USB device number 7 using ehci-pci
[32158.497600] usb 2-1.8: New USB device found, idVendor=8644, idProduct=8003
[32158.497606] usb 2-1.8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[32158.497608] usb 2-1.8: Product: USB Flash Disk                
[32158.497611] usb 2-1.8: Manufacturer: General                       
[32158.497613] usb 2-1.8: SerialNumber: D490EB7867DD4B61
[32158.498224] usb-storage 2-1.8:1.0: USB Mass Storage device detected
[32158.498950] scsi10 : usb-storage 2-1.8:1.0
[32159.499997] scsi 10:0:0:0: Direct-Access     General  USB Flash Disk   1.0  PQ: 0 ANSI: 2
[32159.500720] sd 10:0:0:0: Attached scsi generic sg4 type 0
[32159.500963] sd 10:0:0:0: [sdd] 7831552 512-byte logical blocks: (4.00 GB/3.73 GiB)
[32159.501637] sd 10:0:0:0: [sdd] Write Protect is off
[32159.501640] sd 10:0:0:0: [sdd] Mode Sense: 03 00 00 00
[32159.502315] sd 10:0:0:0: [sdd] No Caching mode page present
[32159.502318] sd 10:0:0:0: [sdd] Assuming drive cache: write through
[32190.521157] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32221.522134] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32252.459034] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32283.396125] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32283.485137] sd 10:0:0:0: [sdd] No Caching mode page present
[32283.485150] sd 10:0:0:0: [sdd] Assuming drive cache: write through
[32314.397104] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32345.334038] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32376.335015] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32407.271950] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32407.358873]  sdd:
[32407.361438] sd 10:0:0:0: [sdd] No Caching mode page present
[32407.361441] sd 10:0:0:0: [sdd] Assuming drive cache: write through
[32438.209876] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32469.273781] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32500.210703] usb 2-1.8: reset high-speed USB device number 7 using ehci-pci
[32523.759500] sd 10:0:0:0: [sdd] Attached SCSI removable disk
[32523.759505] sd 10:0:0:0: timing out command, waited 60s
[32523.759679] usb 2-1.8: USB disconnect, device number 7

Comment 2 Marco Coli 2013-08-11 21:37:56 UTC
Same here. On macmini cannot mount usb3 disk drive with kernel > 3.10.2-301.fc19.i686

Comment 3 Lukas Middendorf 2013-08-11 21:39:07 UTC
Created attachment 785487 [details]
Patch from the upstream bug report

According to the upstream bug report this patch fixes the bug

Comment 4 Josh Boyer 2013-08-15 12:48:40 UTC
*** Bug 991676 has been marked as a duplicate of this bug. ***

Comment 5 Josh Boyer 2013-08-15 12:49:03 UTC
That got pulled into 3.10.7.  It should be in Fedora git later today.

Comment 6 Josh Boyer 2013-08-15 13:06:12 UTC
3.10.7 is now in Fedora git.  Will be in the next build.

Comment 7 Josh Boyer 2013-08-15 14:09:37 UTC
*** Bug 991668 has been marked as a duplicate of this bug. ***

Comment 8 Marco Coli 2013-08-16 09:02:33 UTC
I can confirm that with 3.10.7 , fedora 19, bug is solved.
Thank you

Comment 9 Fedora Update System 2013-08-16 13:39:51 UTC
kernel-3.10.7-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.10.7-200.fc19

Comment 10 Fedora Update System 2013-08-16 13:42:15 UTC
kernel-3.10.7-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.10.7-100.fc18

Comment 11 Fedora Update System 2013-08-16 22:57:00 UTC
Package kernel-3.10.7-200.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.10.7-200.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14865/kernel-3.10.7-200.fc19
then log in and leave karma (feedback).

Comment 12 Enrique V. Bonet Esteban 2013-08-17 08:34:33 UTC
In a Fedora 18 system, the kernel-3.10.7-100.fc18 fix the same problem.

Comment 13 Josh Boyer 2013-08-17 11:51:36 UTC
*** Bug 998100 has been marked as a duplicate of this bug. ***

Comment 14 Fedora Update System 2013-08-18 00:33:03 UTC
kernel-3.10.7-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-08-18 00:36:45 UTC
kernel-3.10.7-200.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Josh Boyer 2013-08-18 11:58:50 UTC
*** Bug 991726 has been marked as a duplicate of this bug. ***

Comment 17 lev 2013-08-19 07:15:11 UTC
My stick is working well. :)
My problem is fixed. So, bug can be closed.
Thnx.

Comment 18 Paolo De Marino 2013-08-21 01:57:36 UTC
Still having the problem after updating to 3.10.7-100.fc18.x86_64. Please advise what information I can post to help fixing it.

Comment 19 Evros 2013-11-01 19:36:05 UTC
Hi all,
i have this info "Linux localhost.localdomain 3.11.6-200.fc19.x86_64 #1 SMP Fri Oct 18 22:34:18 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
"
Still i can not use my usb stick.What would you advise me ?
Thank You


Note You need to log in before you can comment on or make changes to this bug.