Bug 991740 - KDevelop requires a version of Okteta that does not exist in Fedora
KDevelop requires a version of Okteta that does not exist in Fedora
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdevelop (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
:
Depends On: okteta
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 04:44 EDT by Joonas Sarajärvi
Modified: 2013-08-07 10:23 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 10:23:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joonas Sarajärvi 2013-08-04 04:44:30 EDT
Description of problem:

kdevelop-libs is not installable in Rawhide, because the minimum required
version of Okteta is decided from whatever happens to be the current
KDE version at the build environment of kdevelop.

While waiting for a more recent version of Okteta, I think it would be quite
easy to fix this by just explicitly specifying that okteta 4.10 suffices
for kdevelop-libs.

Version-Release number of selected component (if applicable):
kdevelop-libs-4.5.1-2.fc20 (yum is currently offering me this) and
kdevelop-libs-4.5.1-3.fc20 (latest version in koji)

How reproducible:
Always

Steps to Reproduce:
1. yum install kdevelop

Actual results:
Error: Package: 9:kdevelop-libs-4.5.1-2.fc20.x86_64 (rawhide)
           Requires: okteta >= 4.10.97
           Installed: kdesdk-okteta-4.10.4-4.fc20.x86_64 (@rawhide)
               okteta = 4.10.4-4.fc20
           Available: kdesdk-okteta-4.10.4-3.fc20.x86_64 (rawhide)
               okteta = 4.10.4-3.fc20

Expected results:
Get a working copy of kdevelop.
Comment 1 Rex Dieter 2013-08-04 10:16:16 EDT
This is due to once monolithic kdesdk package, being split upstream for kde-4.11.  We're still working on new packaging, and reviews.

A quick (short-term) fix in the meantime would be to simply remove
Requires: okteta >= %{_kde4_version}
from kdevelop.spec
Comment 2 Jan Grulich 2013-08-04 12:21:23 EDT
Should I do it? Or should we wait for okteta update, which may take a long time because we have to create a new package for that and go through fedora-review etc.
Comment 3 Kevin Kofler 2013-08-04 17:56:02 EDT
That will just reduce the pressure to get the reviews completed, which is a bad idea because this is a blocker for pushing 4.11 as an update. It will also mean we will likely forget to readd the dependency later.

IMHO, one of us should file a review request for okteta ASAP and we should mark it as blocking this bug.

As for the reporter: Don't use Rawhide if you want a working system.
Comment 4 Jan Grulich 2013-08-04 18:10:48 EDT
We already have okteta package, which is now obsoleted, because okteta was part of kdeutils since KDE 4.1. What to do in this situation? I'll do it, but I don't know whether I should file a review request and then update the obsoleted package or should I create a new one?
Comment 5 Kevin Kofler 2013-08-04 18:54:55 EDT
Unretiring a package follows the same process as if it were completely new, only the SCM request at the end is different, but it needs a rereview just like a new package review.
Comment 6 Joonas Sarajärvi 2013-08-05 04:03:32 EDT
(In reply to Kevin Kofler from comment #3)
> That will just reduce the pressure to get the reviews completed, which is a
> bad idea because this is a blocker for pushing 4.11 as an update. It will
> also mean we will likely forget to readd the dependency later.
> 
> IMHO, one of us should file a review request for okteta ASAP and we should
> mark it as blocking this bug.
> 
> As for the reporter: Don't use Rawhide if you want a working system.

Rawhide mostly works fine for me, so currently I plan to keep using Rawhide
and reporting issues.

The description at https://fedoraproject.org/wiki/Releases/Rawhide#Goals
does not sound like it would be unreasonable to expect that obviously
broken dependencies get fixed in a timely manner.

Also instead of dropping the okteta dependency, just the version requirement
could be lowered. My impression is that kdevelop does not usually require
experimental, or even the latest stable, version of KDE. A bit older okteta
should work just fine. At least most of kdevelop functionality was ok before
the rebuild that bumped the okteta version requirement.

Please still consider applying the fix, while waiting for the okteta
refactoring work to complete. I can fix this locally for myself, but I would
prefer if Rawhide packages were kept in a usable state, at least in cases
where it is easy to do so.

Note You need to log in before you can comment on or make changes to this bug.