Bug 991777 - drools-persistence-jpa depends on BTM snapshot
drools-persistence-jpa depends on BTM snapshot
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Marco Rietveld
Lukáš Petrovický
: TestBlocker
Depends On:
Blocks: 989519
  Show dependency treegraph
 
Reported: 2013-08-04 06:30 EDT by Lukáš Petrovický
Modified: 2016-09-20 01:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukáš Petrovický 2013-08-04 06:30:42 EDT
https://raw.github.com/droolsjbpm/droolsjbpm-build-bootstrap/master/kie-parent-with-dependencies/pom.xml

Says:

      <dependency>
        <groupId>org.codehaus.btm</groupId>
        <artifactId>btm</artifactId>
        <version>3.0.0-20130426.133011-3</version>
      </dependency>

I am unable to build the project because of that.
Comment 1 Ryan Zhang 2013-08-28 01:57:59 EDT
Assign to Geoffrey since this is a issue needs to fix in upstream.
Comment 3 Geoffrey De Smet 2013-09-11 04:47:41 EDT
btm is used by these modules:
    drools-persistence-jpa
    droolsjbpm-bpms-distribution
    jbpm-audit
    jbpm-bpmn2
    jbpm-console-ng-human-tasks-backend
    jbpm-console-ng-showcase
    jbpm-distribution
    jbpm-executor
    jbpm-form-modeler
    jbpm-human-task
    jbpm-human-task-core
    jbpm-human-task-workitems
    jbpm-kie-services
    jbpm-persistence-jpa
    jbpm-runtime-manager
    jbpm-shared-services
    jbpm-simulation
    jbpm-test
    kie-wb-webapp (ignorable: doesn't use it really, just to workaround an issue)

Looks like most of those are just depending on it to "get stuff to work",
to workaround the problem that drools-persistence-jpa and jbpm-persistence-jpa made it a scope=test dependency, instead of a scope=runtime dependency (which it might need to be).
Comment 4 Geoffrey De Smet 2013-09-11 04:52:38 EDT
Latest version of btm available on nexus is 2.1.2, possible of date "Sun Oct 30 2011".
https://repository.jboss.org/nexus/index.html#nexus-search;gav~org.codehaus.btm~btm~~~~kw,versionexpand

No btm 3.0.0 has been released yet.
Comment 6 Marco Rietveld 2013-09-12 14:50:27 EDT
Fixed with this commit: 

https://github.com/jboss-integration/jboss-integration-platform-bom/commit/9c734550c8708e188686062a2f831f22b833621a

I've released/deployed the artifacts that we'll use here: 
https://repository.jboss.org/nexus/content/groups/public/org/codehaus/btm/btm/3.0.0.Alpha1-jbossorg-1/

The 3.0.0.Alpha1-jbossorg-1 artifacts are based on the btm 3.0.0-SNAPSHOT. The repository (along with the tag) used to create the artifacts can be found here: 
https://github.com/mrietveld/btm/

(Not sure that ER3 is the right milestone? Setting to MODIFIED).
Comment 10 Lukáš Petrovický 2013-10-17 02:33:33 EDT
ER4 no longer depends on BTM snapshot now it's 3.0.0.Alpha1-jbossorg-1. VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.