Bug 99265 - modprobe -c doesn't report USB module uhci_hcd from 2.6.0-test1
Summary: modprobe -c doesn't report USB module uhci_hcd from 2.6.0-test1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: modutils   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-16 19:48 UTC by Matt Domsch
Modified: 2014-03-17 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-28 06:11:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matt Domsch 2003-07-16 19:48:10 UTC
Description of problem:
modprobe -c doesn't report USB module uhci_hcd, as found in
kernel-2.6.0-0.test1.1.25.  Since initscripts-7.28-1 uses a call to modprobe -c
to determine which USB modules to try to load, rc.sysinit fails to load the
uhci_hcd module automatically.

Version-Release number of selected component (if applicable):
modutils-2.4.25-8
initscripts-7.28-1
kernel-2.6.0-0.test1.1.25

How reproducible:
always on Red Hat Linux 9 plus the above packages and 

Steps to Reproduce:
1. modprobe -c | grep usb-controller
2.
3.
    
Actual results:
returns
alias usb-controller usb-uhci


Expected results:
returns
alias usb-controller uhci_hcd
(and other similar lines as appropriate)




Additional info:

Comment 1 Bill Nottingham 2003-07-16 19:50:15 UTC
modprobe under 2.6 doesn't have default config aliases, they have to be
generated by hand. The build script needs to be updated to do some transforms on
the 2.4 builtin alias list.

Comment 2 Bill Nottingham 2004-01-28 06:11:38 UTC
This is fixed in current rawhide modutils.


Note You need to log in before you can comment on or make changes to this bug.