Bug 992907 - Gray start bar of rhel shows in first text terminal of the rhel guest when send key Ctrl+Alt+Backspace followed by Ctrl+Alt+F2
Gray start bar of rhel shows in first text terminal of the rhel guest when se...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
: 992914 (view as bug list)
Depends On:
Blocks: 992914
  Show dependency treegraph
 
Reported: 2013-08-05 03:36 EDT by hyao@redhat.com
Modified: 2014-10-14 04:20 EDT (History)
11 users (show)

See Also:
Fixed In Version: gdm-2.30.4-55.el6
Doc Type: Bug Fix
Doc Text:
Cause: Inadequate logic for determining when to force the X server to run on virtual console 1. Consequence: The login screen and subsequent user sessions jumping to virtual console 7 after the initial log out. Fix: A change in logic to force virtual console 1 for the statically hardwired display. Result: Only auxillary displays needed for user switching run on virtual console 7 and later. The main login screen / user session always runs on virtual console 1.
Story Points: ---
Clone Of:
: 992914 (view as bug list)
Environment:
Last Closed: 2014-10-14 04:20:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
graybar screen shot (1.69 KB, image/png)
2013-08-05 03:36 EDT, hyao@redhat.com
no flags Details

  None (edit)
Description hyao@redhat.com 2013-08-05 03:36:16 EDT
Created attachment 782712 [details]
graybar screen shot

Description of problem:
Gray start bar of rhel shows in first text terminal of the rhel guest when send key Ctrl+Alt+Backspace followed by Ctrl+Alt+F2

Version-Release number of selected component:
virt-viewer-0.5.6-6.el6.x86_64
libvirt-0.10.2-21.el6.x86_64

How reproducible:
100%

Steps:
1. RHEL guest with X running is available.
2. connect to guest by virt-viewer.
#virt-viewer guest_name
3. Go to Send key -> Ctrl+Alt+Backspace
4. Then Send key->Ctrl+Alt+F2
5. Send key->Ctrl+Alt+F1

Actual results:
After step5:Gray starting bar of rhel shows in the first text terminal and stays there until restart the guest.
It reproduce for both vnc and spice. And it reproduce by following the same steps in virt-manager

Expected Results:
Gray starting bar of rhel doesn't show.
Comment 2 Marc-Andre Lureau 2013-08-05 11:23:17 EDT
most likely a qxl driver or server bug
Comment 3 Marc-Andre Lureau 2013-08-14 16:43:34 EDT
that's not a spice bug, the graphical console is on f7.

moving to gdm (I am not sure what component is responsible here)
Comment 4 Ray Strode [halfline] 2014-02-10 09:31:01 EST
*** Bug 992914 has been marked as a duplicate of this bug. ***
Comment 5 Ray Strode [halfline] 2014-02-10 11:46:06 EST
if you don't do steps 4 and 5, what happens?
Comment 6 hyao@redhat.com 2014-02-10 21:38:55 EST
Without steps 4 and 5, just send key combination Ctrl+Alt+Backspace, the guest twinkles and the user login interface displays. 
Ctrl+Alt+Backspace combination restarts X server.
Comment 7 Ray Strode [halfline] 2014-02-11 23:25:01 EST
can you attach /var/log/Xorg.*  after reproducing the bug?
Comment 10 Ray Strode [halfline] 2014-04-03 09:20:12 EDT
okay GDM should try to pick vt1 again and it's not.  devack+
Comment 11 Ray Strode [halfline] 2014-06-19 14:44:17 EDT
backported fix from upstream
Comment 12 Ray Strode [halfline] 2014-06-20 10:59:43 EDT
minor update to avoid some unwanted log spew
Comment 16 errata-xmlrpc 2014-10-14 04:20:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1591.html

Note You need to log in before you can comment on or make changes to this bug.