Bug 992914 - Gray start bar of rhel shows in first text terminal of the rhel guest when send key Ctrl+Alt+Backspace followed by Ctrl+Alt+F2
Gray start bar of rhel shows in first text terminal of the rhel guest when se...
Status: CLOSED DUPLICATE of bug 992907
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On: 992907
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 03:55 EDT by hyao@redhat.com
Modified: 2014-02-10 09:31 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 992907
Environment:
Last Closed: 2014-02-10 09:31:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Christophe Fergeau 2013-11-04 07:57:34 EST
Parent bug was moved to gdm https://bugzilla.redhat.com/show_bug.cgi?id=992907#c3
"that's not a spice bug, the graphical console is on f7.

moving to gdm (I am not sure what component is responsible here)"
Comment 3 Ray Strode [halfline] 2014-01-28 13:32:13 EST
When this is happening, what does:

ps -ef |grep lymouth 

show?
Comment 4 hyao@redhat.com 2014-02-07 03:23:12 EST
(In reply to Ray Strode [halfline] from comment #3)
> When this is happening, what does:
> 
> ps -ef |grep lymouth 
> 
> show?

Get the following on the guest:
# ps -ef | grep lymouth
gdm       2382  2320  0 08:01 ?        00:00:00 plymouth-log-viewer --icon
root      2571  2553  0 08:16 pts/0    00:00:00 grep lymouth

I get the following result on host,
# ps -ef | grep r6
root     13035  7118  0 16:02 pts/3    00:00:00 grep --color=auto r6
qemu     30192     1 14 15:58 ?        00:00:33 /usr/libexec/qemu-kvm -name r6 -S -machine pc-i440fx-rhel7.0.0,accel=kvm,usb=off -m 1024 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 339b8f35-ac79-49dd-a05e-2c6b82e46df0 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/r6.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/var/lib/libvirt/images/kvm-rhel6.4-x86_64-raw.img,if=none,id=drive-ide0-0-0,format=raw,cache=none -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,fd=25,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:28:30:ef,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -chardev spicevmc,id=charchannel0,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.spice.0 -spice port=5901,addr=127.0.0.1,disable-ticketing,seamless-migration=on -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
root     30785  2747  0 15:58 pts/0    00:00:00 virt-viewer r6

Please ping me if more info are needed.
Comment 5 Ray Strode [halfline] 2014-02-07 08:28:46 EST
So it looks like it's just a matter of the screen not getting cleared. What I don't understand is, though...  We don't ship plymouth-log-viewer in rhel7. Did you build plymouth yourself?  is this on a rhel6 machine?  if the latter, can you post the output on a reproducing rhel7 machine?
Comment 6 hyao@redhat.com 2014-02-07 21:58:05 EST
(In reply to Ray Strode [halfline] from comment #5)
> So it looks like it's just a matter of the screen not getting cleared. What
> I don't understand is, though...  We don't ship plymouth-log-viewer in
> rhel7. Did you build plymouth yourself?  is this on a rhel6 machine?  if the
> latter, can you post the output on a reproducing rhel7 machine?

The host is rhel7, I didn't build plymouth-log-viewer.
But the GUEST is rhel6.4, so the output with plymouth-log-viewer listed is on the guest. Sorry for I didn't mention it.
Comment 7 Ray Strode [halfline] 2014-02-10 09:31:01 EST
Okay, the host doesn't really matter. let me remerge this bug with the one it was cloned from.

*** This bug has been marked as a duplicate of bug 992907 ***

Note You need to log in before you can comment on or make changes to this bug.