This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 992923 - SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'search' accesses on the directory dbus.
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'search' accesse...
Status: CLOSED DUPLICATE of bug 992920
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:29d0502edbf0930d91211c7f299...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 04:26 EDT by Samium Gromoff
Modified: 2013-08-05 10:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:05:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 04:26:15 EDT
Description of problem:
I have the following in my /etc/ejabberd/ejabberd.conf:

---- >8 ----
{auth_method, pam}.
{pam_service, "login"}.
---- 8< ----

Essentially, I'm enabling PAM authentication.
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from 'search' accesses on the directory dbus.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that epam should be allowed search access on the dbus directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep epam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:system_dbusd_var_run_t:s0
Target Objects                dbus [ dir ]
Source                        epam
Source Path                   /usr/lib64/ejabberd/priv/bin/epam
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ejabberd-2.1.13-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   15
First Seen                    2013-08-02 17:55:42 MSK
Last Seen                     2013-08-05 11:59:25 MSK
Local ID                      2107af49-3f85-4357-ac84-9e68693283bf

Raw Audit Messages
type=AVC msg=audit(1375689565.271:1584): avc:  denied  { search } for  pid=28188 comm="epam" name="dbus" dev="tmpfs" ino=14670 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:system_dbusd_var_run_t:s0 tclass=dir


type=SYSCALL msg=audit(1375689565.271:1584): arch=x86_64 syscall=connect success=no exit=EACCES a0=3 a1=7fff72421200 a2=21 a3=6e75722f7261762f items=0 ppid=28154 pid=28188 auid=4294967295 uid=991 gid=989 euid=0 suid=0 fsuid=0 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=epam exe=/usr/lib64/ejabberd/priv/bin/epam subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: epam,rabbitmq_beam_t,system_dbusd_var_run_t,dir,search

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:05:25 EDT

*** This bug has been marked as a duplicate of bug 992920 ***

Note You need to log in before you can comment on or make changes to this bug.