Bug 992920 - SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from using the 'setuid' capabilities.
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from using the 'setui...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bf27c97348c18531e3f35142b76...
:
: 992923 992925 992926 992929 992930 992932 992933 992934 992936 992937 992947 992953 992956 992957 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 04:20 EDT by Samium Gromoff
Modified: 2013-08-21 20:53 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-71.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 20:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 04:20:55 EDT
Description of problem:
I have the following in my /etc/ejabberd/ejabberd.conf:

---- >8 ----
{auth_method, pam}.
{pam_service, "login"}.
---- 8< ----

Essentially, I'm enabling PAM authentication.
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from using the 'setuid' capabilities.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that epam should have the setuid capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep epam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:system_r:rabbitmq_beam_t:s0
Target Objects                 [ capability ]
Source                        epam
Source Path                   /usr/lib64/ejabberd/priv/bin/epam
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ejabberd-2.1.13-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   22
First Seen                    2013-08-02 17:55:42 MSK
Last Seen                     2013-08-05 11:59:25 MSK
Local ID                      6ddc8ca2-35c9-43ba-8d27-3c11a7a98190

Raw Audit Messages
type=AVC msg=audit(1375689565.280:1587): avc:  denied  { setuid } for  pid=9920 comm="epam" capability=7  scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:system_r:rabbitmq_beam_t:s0 tclass=capability


type=SYSCALL msg=audit(1375689565.280:1587): arch=x86_64 syscall=setuid success=yes exit=0 a0=0 a1=7fdd36f67e70 a2=7fdd36f653b0 a3=7fdd367502e0 items=0 ppid=28188 pid=9920 auid=4294967295 uid=991 gid=989 euid=0 suid=0 fsuid=0 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=epam exe=/usr/lib64/ejabberd/priv/bin/epam subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: epam,rabbitmq_beam_t,rabbitmq_beam_t,capability,setuid

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:05:25 EDT
*** Bug 992923 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-08-05 10:06:48 EDT
*** Bug 992925 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-08-05 10:16:43 EDT
*** Bug 992926 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-08-05 10:21:39 EDT
*** Bug 992929 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2013-08-05 10:21:52 EDT
*** Bug 992930 has been marked as a duplicate of this bug. ***
Comment 6 Miroslav Grepl 2013-08-05 10:22:59 EDT
*** Bug 992932 has been marked as a duplicate of this bug. ***
Comment 7 Miroslav Grepl 2013-08-05 10:23:11 EDT
*** Bug 992933 has been marked as a duplicate of this bug. ***
Comment 8 Miroslav Grepl 2013-08-05 10:23:59 EDT
I am adding fixes also for duplicated bugs.
Comment 9 Miroslav Grepl 2013-08-05 10:29:58 EDT
*** Bug 992934 has been marked as a duplicate of this bug. ***
Comment 10 Miroslav Grepl 2013-08-05 10:38:33 EDT
*** Bug 992937 has been marked as a duplicate of this bug. ***
Comment 11 Miroslav Grepl 2013-08-05 10:38:37 EDT
*** Bug 992936 has been marked as a duplicate of this bug. ***
Comment 12 Miroslav Grepl 2013-08-05 10:38:49 EDT
*** Bug 992947 has been marked as a duplicate of this bug. ***
Comment 13 Miroslav Grepl 2013-08-05 10:38:54 EDT
*** Bug 992953 has been marked as a duplicate of this bug. ***
Comment 14 Miroslav Grepl 2013-08-05 10:39:00 EDT
*** Bug 992956 has been marked as a duplicate of this bug. ***
Comment 15 Miroslav Grepl 2013-08-05 10:39:09 EDT
*** Bug 992957 has been marked as a duplicate of this bug. ***
Comment 16 Miroslav Grepl 2013-08-05 10:44:02 EDT
commit 4e2afb1784a0f572ccb0223dc825eb7b56d8a094
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Mon Aug 5 16:43:34 2013 +0200

    Add fixes for rabbit to fix ##992920,#992931
Comment 17 Fedora Update System 2013-08-20 04:26:05 EDT
selinux-policy-3.12.1-71.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-71.fc19
Comment 18 Fedora Update System 2013-08-20 20:15:13 EDT
Package selinux-policy-3.12.1-71.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-71.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15088/selinux-policy-3.12.1-71.fc19
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2013-08-21 20:53:02 EDT
selinux-policy-3.12.1-71.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.