Bug 992930 - SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'write' accesses on the file erlang.log.
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'write'...
Status: CLOSED DUPLICATE of bug 992920
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9f1fc60eb8096c02b3c71fda7a2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 04:53 EDT by Samium Gromoff
Modified: 2013-08-05 10:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 04:53:53 EDT
Description of problem:
I'm trying to run ejabberd, and I have SELinux shooting it down during startup.

I have no idea why SELinux would prevent ejabberd from writing to a log file.
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'write' accesses on the file erlang.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that beam.smp should be allowed write access on the erlang.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep beam.smp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:rabbitmq_var_log_t:s0
Target Objects                erlang.log [ file ]
Source                        beam.smp
Source Path                   /usr/lib64/erlang/erts-5.10.1/bin/beam.smp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           erlang-erts-R16B-0.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   4
First Seen                    2013-08-02 17:45:54 MSK
Last Seen                     2013-08-02 17:49:57 MSK
Local ID                      3aaa878d-fb06-4e4e-840f-aaae4bd77d4b

Raw Audit Messages
type=AVC msg=audit(1375451397.625:526): avc:  denied  { write } for  pid=28168 comm="beam.smp" name="erlang.log" dev="dm-3" ino=918699 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:rabbitmq_var_log_t:s0 tclass=file


type=SYSCALL msg=audit(1375451397.625:526): arch=x86_64 syscall=open success=no exit=EACCES a0=7f352c781aa8 a1=241 a2=1b6 a3=0 items=0 ppid=1 pid=28168 auid=4294967295 uid=991 gid=989 euid=991 suid=991 fsuid=991 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=beam.smp exe=/usr/lib64/erlang/erts-5.10.1/bin/beam.smp subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: beam.smp,rabbitmq_beam_t,rabbitmq_var_log_t,file,write

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:21:52 EDT

*** This bug has been marked as a duplicate of bug 992920 ***

Note You need to log in before you can comment on or make changes to this bug.